From 22ec89974b82cdfdb8fa619ebf7447cf04103807 Mon Sep 17 00:00:00 2001
From: Leo Prikler <leo.prikler@student.tugraz.at>
Date: Thu, 25 Jun 2020 15:46:18 +0200
Subject: gnu: mumble: Fix mumble-overlay.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

The canonical mumble-overlay script searches for libmumble.so.1 in various
directories, none of which are relevant in Guix installations and
additionally does some work to match the architecture of the library to that
of the command that will be executed.
This work is unnecessary in Guix and only causes the script to fail, so we
instead just hardcode the path.

* gnu/packages/telephony.scm (mumble)[#:phases]: Add fix-mumble-overlay.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
---
 gnu/packages/telephony.scm | 10 ++++++++++
 1 file changed, 10 insertions(+)

(limited to 'gnu')

diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index 4c84ddc85a..542d36a841 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -588,6 +588,16 @@ (define-public mumble
              (substitute* "src/mumble/Settings.cpp"
                (("bUsage = true;") "bUsage = false;"))
              #t))
+         (add-before 'configure 'fix-mumble-overlay
+           (lambda* (#:key outputs #:allow-other-keys)
+              (with-output-to-file "scripts/mumble-overlay"
+                (lambda ()
+                  (format #t "#!~a~%" (which "bash"))
+                  (format #t "export LD_PRELOAD=\"~a $LD_PRELOAD\"~%"
+                          (string-append (assoc-ref outputs "out")
+                                         "/lib/mumble/libmumble.so.1"))
+                  (format #t "exec \"${@}\"")))
+              #t))
          (add-before 'install 'disable-murmur-ice
            (lambda _
              (substitute* "scripts/murmur.ini.system"
-- 
cgit v1.2.3