From 14e2f61adade2716f7c70e01b4a6cf8be36c6116 Mon Sep 17 00:00:00 2001
From: Ricardo Wurmus <rekado@elephly.net>
Date: Wed, 30 May 2018 08:56:36 +0200
Subject: gnu: gtkglext: Fix build.

* gnu/packages/gnome.scm (gtkglext)[arguments]: Add build phase to fix name
collision.
---
 gnu/packages/gnome.scm | 12 +++++++++++-
 1 file changed, 11 insertions(+), 1 deletion(-)

(limited to 'gnu')

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d04f40548f..3fde8487dd 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -8,7 +8,7 @@
 ;;; Copyright © 2015 Mathieu Lirzin <mthl@openmailbox.org>
 ;;; Copyright © 2015, 2017 Andy Wingo <wingo@igalia.com>
 ;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
-;;; Copyright © 2015, 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2015, 2016, 2017, 2018 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2015 David Thompson <davet@gnu.org>
 ;;; Copyright © 2015, 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
@@ -1070,6 +1070,16 @@ (define-public gtkglext
               (patches (search-patches
                         "gtkglext-disable-disable-deprecated.patch"))))
     (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         ;; Fix a collision between a local variable and a definition from
+         ;; glibc's string.h.
+         (add-after 'unpack 'fix-collision
+           (lambda _
+             (substitute* "gdk/gdkglshapes.c"
+               ((" index") " triangle_index"))
+             #t)))))
     (inputs `(("gtk+" ,gtk+-2)
               ("mesa" ,mesa)
               ("glu" ,glu)
-- 
cgit v1.2.3