From 925fe4b3cece17f564c640f536ebcf24c2af2795 Mon Sep 17 00:00:00 2001
From: Julien Lepiller <julien@lepiller.eu>
Date: Fri, 4 May 2018 21:07:23 +0200
Subject: gnu: coq-coquelicot: Fix for coq 8.8.

* gnu/packages/ocaml.scm (coq-coquelicot)[arguments]: New phase to
remove a deprecated command.
---
 gnu/packages/ocaml.scm | 6 ++++++
 1 file changed, 6 insertions(+)

(limited to 'gnu/packages')

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index c401d4a003..c55276aa9d 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4034,6 +4034,12 @@ (define-public coq-coquelicot
                             "/lib/coq/user-contrib/Coquelicot"))
        #:phases
        (modify-phases %standard-phases
+         (add-before 'configure 'fix-coq8.8
+           (lambda _
+             ; appcontext has been removed from coq 8.8
+             (substitute* "theories/AutoDerive.v"
+               (("appcontext") "context"))
+             #t))
          (add-before 'configure 'fix-remake
            (lambda _
              (substitute* "remake.cpp"
-- 
cgit v1.2.3