From 4237af8529fe5aca945d928624fb94a25156e7dd Mon Sep 17 00:00:00 2001
From: Tobias Geerinckx-Rice <me@tobias.gr>
Date: Fri, 15 Dec 2017 23:13:47 +0100
Subject: gnu: ruby-tzinfo: Update to 1.2.4.

* gnu/packages/ruby.scm (ruby-tzinfo): Update to 1.2.4
---
 gnu/packages/ruby.scm | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

(limited to 'gnu/packages/ruby.scm')

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 34387e5754..3bd91f086b 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7,6 +7,7 @@
 ;;; Copyright © 2015, 2016, 2017 Ben Woodcroft <donttrustben@gmail.com>
 ;;; Copyright © 2017 ng0 <contact.ng0@cryptolab.net>
 ;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2251,14 +2252,14 @@ (define-public ruby-thread-safe
 (define-public ruby-tzinfo
   (package
     (name "ruby-tzinfo")
-    (version "1.2.3")
+    (version "1.2.4")
     (source
      (origin
        (method url-fetch)
        (uri (rubygems-uri "tzinfo" version))
        (sha256
         (base32
-         "05r81lk7q7275rdq7xipfm0yxgqyd2ggh73xpc98ypngcclqcscl"))))
+         "09dpbrih054mn42flbbcdpzk2727mzfvjrgqb12zdafhx7p9rrzp"))))
     (build-system ruby-build-system)
     (propagated-inputs
      `(("ruby-thread-safe" ,ruby-thread-safe)))
-- 
cgit v1.2.3


From 925131916d3b1ee45533b7300d53a8a0db8672a6 Mon Sep 17 00:00:00 2001
From: Tobias Geerinckx-Rice <me@tobias.gr>
Date: Sat, 23 Dec 2017 05:14:34 +0100
Subject: gnu: ruby-tzinfo-data: Update to 1.2017.3.

* gnu/packages/ruby.scm (ruby-tzinfo-data): Update to 1.2017.3
---
 gnu/packages/ruby.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

(limited to 'gnu/packages/ruby.scm')

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 3bd91f086b..19b23fe665 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -2272,7 +2272,7 @@ (define-public ruby-tzinfo
 (define-public ruby-tzinfo-data
   (package
     (name "ruby-tzinfo-data")
-    (version "1.2016.9")
+    (version "1.2017.3")
     (source
      (origin
        (method url-fetch)
@@ -2285,7 +2285,7 @@ (define-public ruby-tzinfo-data
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
         (base32
-         "0i8vz2j7wmcpr4pd066qvlg4if5blscjrgxk2imavfa49nq5lp06"))
+         "01wff7syqzikbxalbg3isgxasmvzicr85bzadzkb6bf20bip4v54"))
        ;; Remove the known test failure.
        ;; https://github.com/tzinfo/tzinfo-data/issues/10
        ;; https://bugs.launchpad.net/ubuntu/+source/glibc/+bug/1587128
-- 
cgit v1.2.3


From 2f3800e53e5d7158863f702599c8190962a80226 Mon Sep 17 00:00:00 2001
From: Tobias Geerinckx-Rice <me@tobias.gr>
Date: Sat, 23 Dec 2017 05:49:47 +0100
Subject: gnu: ruby: Use HTTPS for home pages.

* gnu/packages/ruby.scm (ruby-hoe, bundler, ruby-rjb, ruby-libxml)
(ruby-permutation, ruby-gettext, ruby-test-unit, ruby-pry, ruby-tzinfo)
(ruby-tzinfo-data, ruby-term-ansicolor, ruby-pstree, ruby-json, ruby-rack)
(ruby-yard, ruby-ansi, ruby-rubytest, ruby-brass, ruby-qed, ruby-ae)
(ruby-lemon, ruby-rubytest-cli, ruby-hashery)[home-page]: Use HTTPS.
---
 gnu/packages/ruby.scm | 46 +++++++++++++++++++++++-----------------------
 1 file changed, 23 insertions(+), 23 deletions(-)

(limited to 'gnu/packages/ruby.scm')

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 19b23fe665..c66c0a4143 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -266,7 +266,7 @@ (define-public ruby-hoe
 for easy extensibility.  Hoe ships with plug-ins for all the usual project
 tasks including rdoc generation, testing, packaging, deployment, and
 announcement.")
-    (home-page "http://www.zenspider.com/projects/hoe.html")
+    (home-page "https://www.zenspider.com/projects/hoe.html")
     (license license:expat)))
 
 (define-public ruby-rake-compiler
@@ -509,7 +509,7 @@ (define-public bundler
     (synopsis "Ruby gem bundler")
     (description "Bundler automatically downloads and installs a list of gems
 specified in a \"Gemfile\", as well as their dependencies.")
-    (home-page "http://bundler.io/")
+    (home-page "https://bundler.io/")
     (license license:expat)))
 
 (define-public ruby-builder
@@ -562,7 +562,7 @@ (define-public ruby-rjb
     (synopsis "Ruby-to-Java bridge using the Java Native Interface")
     (description "RJB is a bridge program that connects Ruby and Java via the
 Java Native Interface.")
-    (home-page "http://www.artonx.org/collabo/backyard/?RubyJavaBridge")
+    (home-page "https://www.artonx.org/collabo/backyard/?RubyJavaBridge")
     (license license:lgpl2.1+)))
 
 (define-public ruby-log4r
@@ -765,7 +765,7 @@ (define-public ruby-libxml
     (synopsis "Ruby bindings for GNOME Libxml2")
     (description "The Libxml-Ruby project provides Ruby language bindings for
 the GNOME Libxml2 XML toolkit.")
-    (home-page "http://xml4r.github.com/libxml-ruby")
+    (home-page "https://xml4r.github.com/libxml-ruby")
     (license license:expat)))
 
 (define-public ruby-xml-simple
@@ -879,7 +879,7 @@ (define-public ruby-permutation
     (synopsis "Library to perform operations with sequence permutations")
     (description "This package provides a Ruby library to perform different
 operations with permutations of sequences, such as strings and arrays.")
-    (home-page "http://flori.github.io/permutation")
+    (home-page "https://flori.github.io/permutation")
     (license license:gpl2))) ; GPL 2 only
 
 (define-public ruby-shellany
@@ -1252,7 +1252,7 @@ (define-public ruby-gettext
      "Gettext is a GNU gettext-like program for Ruby.  The catalog
 file (po-file) used is the same as that used by GNU gettext, allowing you to
 use GNU gettext tools for maintenance.")
-    (home-page "http://ruby-gettext.github.com/")
+    (home-page "https://ruby-gettext.github.com/")
     (license (list license:lgpl3+ license:ruby))))
 
 (define-public ruby-packnga
@@ -1302,7 +1302,7 @@ (define-public ruby-test-unit
 on xUnit principles.  These were originally designed by Kent Beck, creator of
 extreme programming software development methodology, for Smalltalk's SUnit.
 It allows writing tests, checking results and automated testing in Ruby.")
-    (home-page "http://test-unit.github.io/")
+    (home-page "https://test-unit.github.io/")
     (license (list license:psfl license:ruby))))
 
 (define-public ruby-metaclass
@@ -2178,7 +2178,7 @@ (define-public ruby-pry
     (description "Pry is an IRB alternative and runtime developer console for
 Ruby.  It features syntax highlighting, a plugin architecture, runtime
 invocation, and source and documentation browsing.")
-    (home-page "http://pryrepl.org")
+    (home-page "https://pryrepl.org")
     (license license:expat)))
 
 (define-public ruby-guard
@@ -2266,7 +2266,7 @@ (define-public ruby-tzinfo
     (synopsis "Time zone library for Ruby")
     (description "TZInfo is a Ruby library that provides daylight savings
 aware transformations between times in different time zones.")
-    (home-page "http://tzinfo.github.io")
+    (home-page "https://tzinfo.github.io")
     (license license:expat)))
 
 (define-public ruby-tzinfo-data
@@ -2298,7 +2298,7 @@ (define-public ruby-tzinfo-data
     (description
      "This library provides @code{TZInfo::Data}, which contains data from the
 IANA Time Zone database packaged as Ruby modules for use with @code{TZInfo}.")
-    (home-page "http://tzinfo.github.io")
+    (home-page "https://tzinfo.github.io")
     (license license:expat)))
 
 (define-public ruby-rb-inotify
@@ -2530,7 +2530,7 @@ (define-public ruby-term-ansicolor
     (description
      "This Ruby library uses ANSI escape sequences to control the attributes
 of terminal output.")
-    (home-page "http://flori.github.io/term-ansicolor/")
+    (home-page "https://flori.github.io/term-ansicolor/")
     ;; There is no mention of the "or later" clause.
     (license license:gpl2)))
 
@@ -2552,7 +2552,7 @@ (define-public ruby-pstree
     (description
      "This library uses the output of the @code{ps} command to create a
 process tree data structure for the current host.")
-    (home-page "http://flori.github.com/pstree")
+    (home-page "https://github.com/flori/pstree")
     ;; There is no mention of the "or later" clause.
     (license license:gpl2)))
 
@@ -2636,7 +2636,7 @@ (define-public ruby-json-pure
     (synopsis "JSON implementation in pure Ruby")
     (description
      "This package provides a JSON implementation written in pure Ruby.")
-    (home-page "http://flori.github.com/json")
+    (home-page "https://flori.github.com/json")
     (license license:ruby)))
 
 ;; Even though this package only provides bindings for a Mac OSX API it is
@@ -3108,7 +3108,7 @@ (define-public ruby-rack
 developing web applications in Ruby.  By wrapping HTTP requests and responses,
 it unifies the API for web servers, web frameworks, and software in between
 into a single method call.")
-    (home-page "http://rack.github.io/")
+    (home-page "https://rack.github.io/")
     (license license:expat)))
 
 (define-public ruby-docile
@@ -3237,7 +3237,7 @@ (define-public ruby-yard
 language.  It enables the user to generate consistent, usable documentation
 that can be exported to a number of formats very easily, and also supports
 extending for custom Ruby constructs such as custom class level definitions.")
-    (home-page "http://yardoc.org")
+    (home-page "https://yardoc.org")
     (license license:expat)))
 
 (define-public ruby-clap
@@ -3795,7 +3795,7 @@ (define-public ruby-ansi
 @code{ProgressBar}, and a @code{String} subclass.  The library also includes a
 @code{Terminal} module which provides information about the current output
 device.")
-    (home-page "http://rubyworks.github.io/ansi")
+    (home-page "https://rubyworks.github.io/ansi")
     (license license:bsd-2)))
 
 (define-public ruby-systemu
@@ -3890,7 +3890,7 @@ (define-public ruby-rubytest
      "Rubytest is a testing meta-framework for Ruby.  It can handle any
 compliant test framework and can run tests from multiple frameworks in a
 single pass.")
-    (home-page "http://rubyworks.github.io/rubytest")
+    (home-page "https://rubyworks.github.io/rubytest")
     (license license:bsd-2)))
 
 (define-public ruby-brass
@@ -3918,7 +3918,7 @@ (define-public ruby-brass
      "BRASS (Bare-Metal Ruby Assertion System Standard) is a basic
 foundational assertions framework for other assertion and test frameworks to
 make use of.")
-    (home-page "http://rubyworks.github.io/brass")
+    (home-page "https://rubyworks.github.io/brass")
     (license license:bsd-2)))
 
 (define-public ruby-qed
@@ -3951,7 +3951,7 @@ (define-public ruby-qed
 Development} (BDD) utilizing Literate Programming techniques.  QED sits
 somewhere between lower-level testing tools like @code{Test::Unit} and
 requirement specifications systems like Cucumber.")
-    (home-page "http://rubyworks.github.io/qed")
+    (home-page "https://rubyworks.github.io/qed")
     (license license:bsd-2)))
 
 (define-public ruby-ae
@@ -3994,7 +3994,7 @@ (define-public ruby-ae
     (description
      "Assertive Expressive (AE) is an assertions library specifically designed
 for reuse by other test frameworks.")
-    (home-page "http://rubyworks.github.io/ae")
+    (home-page "https://rubyworks.github.io/ae")
     (license license:bsd-2)))
 
 (define-public ruby-lemon
@@ -4024,7 +4024,7 @@ (define-public ruby-lemon
      "Lemon is a unit testing framework that enforces highly formal
 case-to-class and unit-to-method test construction.  This enforcement can help
 focus concern on individual units of behavior.")
-    (home-page "http://rubyworks.github.io/lemon")
+    (home-page "https://rubyworks.github.io/lemon")
     (license license:bsd-2)))
 
 (define-public ruby-rubytest-cli
@@ -4048,7 +4048,7 @@ (define-public ruby-rubytest-cli
     (description
      "Rubytest CLI is a command-line interface for running tests for
 Rubytest-based test frameworks.  It provides the @code{rubytest} executable.")
-    (home-page "http://rubyworks.github.io/rubytest-cli")
+    (home-page "https://rubyworks.github.io/rubytest-cli")
     (license license:bsd-2)))
 
 (define-public ruby-hashery
@@ -4083,7 +4083,7 @@ (define-public ruby-hashery
 defines a CRUD (Create, Read, Update and Delete) model on top of Ruby's
 standard @code{Hash} making it possible to subclass and augment to fit any
 specific use case.")
-    (home-page "http://rubyworks.github.io/hashery")
+    (home-page "https://rubyworks.github.io/hashery")
     (license license:bsd-2)))
 
 (define-public ruby-rc4
-- 
cgit v1.2.3


From bf3be6a5039f62994fb0b579ce6c450c74c76cdb Mon Sep 17 00:00:00 2001
From: ng0 <ng0@n0.is>
Date: Wed, 13 Dec 2017 22:05:37 +0000
Subject: gnu: ruby: Use new home page.

The certificate for ruby-lang.org is only valid for lists.ruby-lang.org,
the home page has moved to www.ruby-lang.org with its own certificate.

* gnu/packages/ruby.scm (ruby)[home-page]: Use 'www.ruby-lang.org'.
---
 gnu/packages/ruby.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

(limited to 'gnu/packages/ruby.scm')

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index c66c0a4143..968a059993 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5,7 +5,7 @@
 ;;; Copyright © 2014, 2015 David Thompson <davet@gnu.org>
 ;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2015, 2016, 2017 Ben Woodcroft <donttrustben@gmail.com>
-;;; Copyright © 2017 ng0 <contact.ng0@cryptolab.net>
+;;; Copyright © 2017 ng0 <ng0@n0.is>
 ;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
@@ -101,7 +101,7 @@ (define-public ruby
     (synopsis "Programming language interpreter")
     (description "Ruby is a dynamic object-oriented programming language with
 a focus on simplicity and productivity.")
-    (home-page "https://ruby-lang.org")
+    (home-page "https://www.ruby-lang.org")
     (license license:ruby)))
 
 (define-public ruby-2.4.3
-- 
cgit v1.2.3


From 405cb5ab8218292c59e1d9368c99f6b9a491830f Mon Sep 17 00:00:00 2001
From: Tobias Geerinckx-Rice <me@tobias.gr>
Date: Sat, 23 Dec 2017 17:51:36 +0100
Subject: gnu: ruby-highline: Update to 1.7.10.

* gnu/packages/ruby.scm (ruby-highline): Update to 1.7.10
---
 gnu/packages/ruby.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

(limited to 'gnu/packages/ruby.scm')

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 968a059993..9ef53c4723 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -225,14 +225,14 @@ (define (gem-directory ruby-version)
 (define-public ruby-highline
   (package
     (name "ruby-highline")
-    (version "1.7.8")
+    (version "1.7.10")
     (source
      (origin
        (method url-fetch)
        (uri (rubygems-uri "highline" version))
        (sha256
         (base32
-         "1nf5lgdn6ni2lpfdn4gk3gi47fmnca2bdirabbjbz1fk9w4p8lkr"))))
+         "01ib7jp85xjc4gh4jg0wyzllm46hwv8p0w1m4c75pbgi41fps50y"))))
     (build-system ruby-build-system)
     (arguments
      `(#:tests? #f)) ;; TODO: NameError: uninitialized constant SPEC
-- 
cgit v1.2.3


From fb812f7a2e2d752054f0aa2b4e7e97d645167008 Mon Sep 17 00:00:00 2001
From: Tobias Geerinckx-Rice <me@tobias.gr>
Date: Fri, 15 Dec 2017 12:58:06 +0100
Subject: gnu: ruby-crass: Update to 1.0.3.

* gnu/packages/ruby.scm (ruby-crass): Update to 1.0.3
---
 gnu/packages/ruby.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

(limited to 'gnu/packages/ruby.scm')

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 9ef53c4723..60ce4cf6ac 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -2718,13 +2718,13 @@ (define-public ruby-activesupport
 (define-public ruby-crass
   (package
     (name "ruby-crass")
-    (version "1.0.2")
+    (version "1.0.3")
     (source (origin
               (method url-fetch)
               (uri (rubygems-uri "crass" version))
               (sha256
                (base32
-                "1c377r8g7m58y22803iyjgqkkvnnii0pymskda1pardxrzaighj9"))))
+                "1czijxlagzpzwchr2ldrgfi7kywg08idjpq37ndcmwh4fmz72c4l"))))
     (build-system ruby-build-system)
     (native-inputs
      `(("bundler" ,bundler)
-- 
cgit v1.2.3


From f03153db004fbe9e81732ef23e8adbb284aada0e Mon Sep 17 00:00:00 2001
From: Tobias Geerinckx-Rice <me@tobias.gr>
Date: Fri, 15 Dec 2017 15:25:58 +0100
Subject: gnu: ruby-daemons: Update to 1.2.5.

* gnu/packages/ruby.scm (ruby-daemons): Update to 1.2.5
---
 gnu/packages/ruby.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

(limited to 'gnu/packages/ruby.scm')

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 60ce4cf6ac..92bf387048 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1833,13 +1833,13 @@ (define-public ruby-minitest-hooks
 (define-public ruby-daemons
   (package
     (name "ruby-daemons")
-    (version "1.2.4")
+    (version "1.2.5")
     (source (origin
               (method url-fetch)
               (uri (rubygems-uri "daemons" version))
               (sha256
                (base32
-                "1bmb4qrd95b5gl3ym5j3q6mf090209f4vkczggn49n56w6s6zldz"))))
+                "15smbsg0gxb7nf0nrlnplc68y0cdy13dm6fviavpmw7c630sring"))))
     (build-system ruby-build-system)
     (arguments
      `(#:tests? #f)) ; no test suite
-- 
cgit v1.2.3


From 05f2f8bcdeacfeb9c15dfa49fe577d8b070bf236 Mon Sep 17 00:00:00 2001
From: Tobias Geerinckx-Rice <me@tobias.gr>
Date: Fri, 15 Dec 2017 13:19:01 +0100
Subject: gnu: ruby-hoe: Update to 3.16.2.

* gnu/packages/ruby.scm (ruby-hoe): Update to 3.16.2
---
 gnu/packages/ruby.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

(limited to 'gnu/packages/ruby.scm')

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 92bf387048..e28b20bcd3 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -251,13 +251,13 @@ (define-public ruby-highline
 (define-public ruby-hoe
   (package
     (name "ruby-hoe")
-    (version "3.16.0")
+    (version "3.16.2")
     (source (origin
               (method url-fetch)
               (uri (rubygems-uri "hoe" version))
               (sha256
                (base32
-                "03r8nsw4n4mnia9iqiqk9kqhvrl96m2i81j4yg8cpnppd8vk7vlb"))))
+                "12q6dn2irsfamdbjpqvs0dwl4i1vl7wflxrcg972h9jw0ds38f3a"))))
     (build-system ruby-build-system)
     (synopsis "Ruby project management helper")
     (description
-- 
cgit v1.2.3


From 1bf02b203603c1d5cfbea49b2a7cbb5dad3013b4 Mon Sep 17 00:00:00 2001
From: Tobias Geerinckx-Rice <me@tobias.gr>
Date: Fri, 15 Dec 2017 15:22:44 +0100
Subject: gnu: ruby-pry: Update to 0.11.3.

* gnu/packages/ruby.scm (ruby-pry): Update to 0.11.3
---
 gnu/packages/ruby.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

(limited to 'gnu/packages/ruby.scm')

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index e28b20bcd3..85b9c98c0a 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -2160,14 +2160,14 @@ (define-public ruby-progress_bar
 (define-public ruby-pry
   (package
     (name "ruby-pry")
-    (version "0.11.1")
+    (version "0.11.3")
     (source
      (origin
        (method url-fetch)
        (uri (rubygems-uri "pry" version))
        (sha256
         (base32
-         "0ci461a55sn50rlrmcl97ycf79681glp443a2gzp23rnm7y70fkj"))))
+         "1mh312k3y94sj0pi160wpia0ps8f4kmzvm505i6bvwynfdh7v30g"))))
     (build-system ruby-build-system)
     (arguments
      '(#:tests? #f)) ; no tests
-- 
cgit v1.2.3


From 53fd476fa5a5e9c5688c0ca21a7b7ebb62b8d9cb Mon Sep 17 00:00:00 2001
From: Tobias Geerinckx-Rice <me@tobias.gr>
Date: Fri, 15 Dec 2017 19:23:59 +0100
Subject: gnu: ruby-simplecov-html: Update to 0.10.2.

* gnu/packages/ruby.scm (ruby-simplecov-html): Update to 0.10.2
---
 gnu/packages/ruby.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

(limited to 'gnu/packages/ruby.scm')

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 85b9c98c0a..28636fab9e 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1045,13 +1045,13 @@ (define-public ruby-rubyzip
 (define-public ruby-simplecov-html
   (package
     (name "ruby-simplecov-html")
-    (version "0.10.1")
+    (version "0.10.2")
     (source (origin
               (method url-fetch)
               (uri (rubygems-uri "simplecov-html" version))
               (sha256
                (base32
-                "0f3psphismgp6jp1fxxz09zbswh7m2xxxr6gqlzdh7sgv415clvm"))))
+                "1lihraa4rgxk8wbfl77fy9sf0ypk31iivly8vl3w04srd7i0clzn"))))
     (build-system ruby-build-system)
     (arguments `(#:tests? #f)) ; there are no tests
     (native-inputs
-- 
cgit v1.2.3


From 0c9f73cd23f3cd5af2ea9076048bd7ea557b69c3 Mon Sep 17 00:00:00 2001
From: Tobias Geerinckx-Rice <me@tobias.gr>
Date: Sun, 24 Dec 2017 15:45:12 +0100
Subject: gnu: ruby-json-pure: Fix build failure.

* gnu/packages/ruby.scm (ruby-json-pure)[native-inputs]: Add ragel.
---
 gnu/packages/ruby.scm | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

(limited to 'gnu/packages/ruby.scm')

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 28636fab9e..827295cb1c 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -2631,8 +2631,9 @@ (define-public ruby-json-pure
              (zero? (system* "rake" "gemspec")))))))
     (native-inputs
      `(("bundler" ,bundler)
-       ("ruby-test-unit" ,ruby-test-unit)
-       ("ruby-simplecov" ,ruby-simplecov)))
+       ("ragel" ,ragel)
+       ("ruby-simplecov" ,ruby-simplecov)
+       ("ruby-test-unit" ,ruby-test-unit)))
     (synopsis "JSON implementation in pure Ruby")
     (description
      "This package provides a JSON implementation written in pure Ruby.")
-- 
cgit v1.2.3


From f90c25c1c84071d42a652396d290582ceef9b6ed Mon Sep 17 00:00:00 2001
From: Clément Lassieur <clement@lassieur.org>
Date: Wed, 27 Dec 2017 17:03:08 +0100
Subject: gnu: Add ruby-rubypants.

* gnu/packages/ruby.scm (ruby-rubypants): New variable.
---
 gnu/packages/ruby.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

(limited to 'gnu/packages/ruby.scm')

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 827295cb1c..69dd6a8365 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -4467,3 +4467,25 @@ (define-public ruby-code-statistics
 more robust and work for non rails projects.")
     (home-page "http://github.com/danmayer/code_statistics")
     (license license:expat)))
+
+(define-public ruby-rubypants
+  (package
+    (name "ruby-rubypants")
+    (version "0.6.0")
+    (source (origin
+              (method url-fetch)
+              (uri (rubygems-uri "rubypants" version))
+              (sha256
+               (base32
+                "0xpqkslan2wkyal2h9qhplkr5d4sdn7q6csigrhnljjpp8j4qfsh"))))
+    (build-system ruby-build-system)
+    (arguments
+     '(#:tests? #f)) ; need Codecov
+    (synopsis "Port of the smart-quotes library SmartyPants")
+    (description
+     "RubyPants is a Ruby port of the smart-quotes library SmartyPants.  The
+original SmartyPants is a web publishing plug-in for Movable Type, Blosxom,
+and BBEdit that easily translates plain ASCII punctuation characters into
+smart typographic punctuation HTML entities.")
+    (home-page "https://github.com/jmcnevin/rubypants")
+    (license license:bsd-2)))
-- 
cgit v1.2.3


From beb3483553d2646cae45a72827b5c3a79f4d9d12 Mon Sep 17 00:00:00 2001
From: Clément Lassieur <clement@lassieur.org>
Date: Wed, 27 Dec 2017 17:02:28 +0100
Subject: gnu: Add ruby-org-ruby.

* gnu/packages/ruby.scm (ruby-org-ruby): New variable.
---
 gnu/packages/ruby.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

(limited to 'gnu/packages/ruby.scm')

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 69dd6a8365..81578d70e0 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -4489,3 +4489,26 @@ (define-public ruby-rubypants
 smart typographic punctuation HTML entities.")
     (home-page "https://github.com/jmcnevin/rubypants")
     (license license:bsd-2)))
+
+(define-public ruby-org-ruby
+  (package
+    (name "ruby-org-ruby")
+    (version "0.9.12")
+    (source (origin
+              (method url-fetch)
+              (uri (rubygems-uri "org-ruby" version))
+              (sha256
+               (base32
+                "0x69s7aysfiwlcpd9hkvksfyld34d8kxr62adb59vjvh8hxfrjwk"))))
+    (build-system ruby-build-system)
+    (arguments
+     '(#:tests? #f)) ; no rakefile
+    (propagated-inputs
+     `(("ruby-rubypants" ,ruby-rubypants)))
+    (synopsis "Org-mode parser written in Ruby")
+    (description
+     "Org-ruby is an org-mode parser written in Ruby.  The most significant
+thing this library does today is convert org-mode files to HTML or Textile or
+Markdown.")
+    (home-page "https://github.com/wallyqs/org-ruby")
+    (license license:expat)))
-- 
cgit v1.2.3


From 6a9d2266657b264708046002671cedaf03092cc1 Mon Sep 17 00:00:00 2001
From: Clément Lassieur <clement@lassieur.org>
Date: Thu, 28 Dec 2017 18:42:57 +0100
Subject: gnu: Add missing copyright line.

* gnu/packages/ruby.scm: Add missing copyright line for commit f90c25c.
---
 gnu/packages/ruby.scm | 1 +
 1 file changed, 1 insertion(+)

(limited to 'gnu/packages/ruby.scm')

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 81578d70e0..2741bd6b7d 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -8,6 +8,7 @@
 ;;; Copyright © 2017 ng0 <ng0@n0.is>
 ;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
-- 
cgit v1.2.3