From 847aa3942b5edea04d56dfb75ad1d88a3e9bb256 Mon Sep 17 00:00:00 2001
From: Tobias Geerinckx-Rice <me@tobias.gr>
Date: Sun, 29 May 2022 02:00:00 +0200
Subject: gnu: micropython: Don't override 'install-license-files.

* gnu/packages/python.scm (micropython)[arguments]: Prefix a new
'chdir-back phase instead of overriding 'install-license-files.
---
 gnu/packages/python.scm | 9 +++------
 1 file changed, 3 insertions(+), 6 deletions(-)

(limited to 'gnu/packages/python.scm')

diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 1727024bfe..ad475d8acc 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -704,13 +704,10 @@ (define-public micropython
                    ;; see: https://github.com/micropython/micropython/pull/4246
                    (substitute* "Makefile"
                      (("-Os") "-Os -ffp-contract=off"))))
-               (replace 'install-license-files
+               (add-before 'install-license-files 'chdir-back
                  ;; We don't build in the root directory so the file isn't found.
-                 (lambda* (#:key outputs #:allow-other-keys)
-                   (let* ((out  (assoc-ref outputs "out"))
-                          (doc (string-append out "/share/doc/"
-                                              #$name "-" #$version "/")))
-                     (install-file "../../LICENSE" doc))))
+                 (lambda _
+                   (chdir "../..")))
                (delete 'configure))       ; no configure
            #:make-flags
            #~(list (string-append "PREFIX=" #$output)
-- 
cgit v1.2.3