From ae3909eb4c36255834b5780ad8aa29055181c964 Mon Sep 17 00:00:00 2001
From: Marius Bakke <mbakke@fastmail.com>
Date: Sun, 19 Jan 2020 20:36:24 +0100
Subject: gnu: python-parameterized: Update to 0.7.1.

* gnu/packages/patches/python2-parameterized-docstring-test.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/check.scm (python-parameterized): Update to 0.7.1.
[arguments]: Remove #:tests?.  Add #:phases to override 'check' phase.
[native-inputs]: Add PYTHON-MOCK and PYTHON-NOSE.
[properties]: New field.
(python2-parameterized)[source](patches): New field.
---
 .../patches/python2-parameterized-docstring-test.patch | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)
 create mode 100644 gnu/packages/patches/python2-parameterized-docstring-test.patch

(limited to 'gnu/packages/patches/python2-parameterized-docstring-test.patch')

diff --git a/gnu/packages/patches/python2-parameterized-docstring-test.patch b/gnu/packages/patches/python2-parameterized-docstring-test.patch
new file mode 100644
index 0000000000..14691e1904
--- /dev/null
+++ b/gnu/packages/patches/python2-parameterized-docstring-test.patch
@@ -0,0 +1,18 @@
+Skip unicode docstring test, required when running on Python 2.
+
+See <https://github.com/wolever/parameterized/issues/44>.
+
+--- a/parameterized/test.py
++++ b/parameterized/test.py
+@@ -284,11 +284,6 @@
+             "        More" %(foo, )
+         )
+ 
+-    @parameterized.expand([param("foo")])
+-    def test_unicode_docstring(self, foo):
+-        u"""Döcumentation."""
+-        self._assert_docstring(u"Döcumentation [with foo=%r]." %(foo, ))
+-
+     @parameterized.expand([param("foo", )])
+     def test_default_values_get_correct_value(self, foo, bar=12):
+         """Documentation"""
-- 
cgit v1.2.3