From 4c50e5ab3a393c6d86fc6362c58f7ecf32dd9680 Mon Sep 17 00:00:00 2001
From: Mark H Weaver <mhw@netris.org>
Date: Fri, 12 Jun 2015 03:24:12 -0400
Subject: gnu: python: Disable ssl test that fails with openssl-1.0.2b.

* gnu/packages/patches/python-disable-ssl-test.patch: New file.
* gnu-system.am (dist_patch_DATA): Add it.
* gnu/packages/python.scm (python): Add patch.
---
 gnu/packages/patches/python-disable-ssl-test.patch | 12 ++++++++++++
 1 file changed, 12 insertions(+)
 create mode 100644 gnu/packages/patches/python-disable-ssl-test.patch

(limited to 'gnu/packages/patches/python-disable-ssl-test.patch')

diff --git a/gnu/packages/patches/python-disable-ssl-test.patch b/gnu/packages/patches/python-disable-ssl-test.patch
new file mode 100644
index 0000000000..e351c77505
--- /dev/null
+++ b/gnu/packages/patches/python-disable-ssl-test.patch
@@ -0,0 +1,12 @@
+Disable a test that fails with openssl-1.0.2b.
+
+--- Lib/test/test_ssl.py.orig	2015-02-25 06:27:45.000000000 -0500
++++ Lib/test/test_ssl.py	2015-06-12 03:14:09.395212502 -0400
+@@ -2718,6 +2718,7 @@
+                                        chatty=True, connectionchatty=True)
+             self.assertIs(stats['compression'], None)
+ 
++        @unittest.skipIf(True, "openssl 1.0.2b complains: dh key too small")
+         def test_dh_params(self):
+             # Check we can get a connection with ephemeral Diffie-Hellman
+             context = ssl.SSLContext(ssl.PROTOCOL_TLSv1)
-- 
cgit v1.2.3