From a2ab82db9ab5d6db86762924d3016aed7c26c315 Mon Sep 17 00:00:00 2001
From: Ludovic Courtès <ludo@gnu.org>
Date: Tue, 5 Jan 2016 12:35:30 +0100
Subject: gnu: python: Honor 'C_INCLUDE_PATH'.

This is a followup to 009b53fd.

* gnu/packages/patches/python-3-search-paths.patch: Check
'C_INCLUDE_PATH' instead of 'CPATH'.
* gnu/packages/patches/python-2.7-search-paths.patch: Likewise.
---
 gnu/packages/patches/python-2.7-search-paths.patch | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

(limited to 'gnu/packages/patches/python-2.7-search-paths.patch')

diff --git a/gnu/packages/patches/python-2.7-search-paths.patch b/gnu/packages/patches/python-2.7-search-paths.patch
index 6e5339f3a6..ba7235df27 100644
--- a/gnu/packages/patches/python-2.7-search-paths.patch
+++ b/gnu/packages/patches/python-2.7-search-paths.patch
@@ -1,5 +1,5 @@
-Make sure the build system honors CPATH and LIBRARY_PATH when looking for
-headers and libraries.
+Make sure the build system honors C_INCLUDE_PATH and LIBRARY_PATH when
+looking for headers and libraries.
 
 --- Python-2.7.10/setup.py	2015-10-07 18:33:18.125153186 +0200
 +++ Python-2.7.10/setup.py	2015-10-07 18:33:47.497347552 +0200
@@ -9,7 +9,7 @@ headers and libraries.
  
 +        # Always honor these variables.
 +        lib_dirs += os.getenv('LIBRARY_PATH', '').split(os.pathsep)
-+        inc_dirs += os.getenv('CPATH', '').split(os.pathsep)
++        inc_dirs += os.getenv('C_INCLUDE_PATH', '').split(os.pathsep)
 +
          # OSF/1 and Unixware have some stuff in /usr/ccs/lib (like -ldb)
          if host_platform in ['osf1', 'unixware7', 'openunix8']:
-- 
cgit v1.2.3