From e9afd8a00595fdc07a0df3a7680cecdb8aa16df7 Mon Sep 17 00:00:00 2001
From: Marius Bakke <marius@gnu.org>
Date: Thu, 11 Aug 2022 19:22:15 +0200
Subject: gnu: LLVM: Add missing include statement for compatibility with GCC
 11.

* gnu/packages/patches/llvm-8-missing-include.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/llvm.scm (llvm-11, llvm-10, llvm-9, llvm-8)[source](patches):
Add it.
---
 gnu/packages/patches/llvm-8-missing-include.patch | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)
 create mode 100644 gnu/packages/patches/llvm-8-missing-include.patch

(limited to 'gnu/packages/patches/llvm-8-missing-include.patch')

diff --git a/gnu/packages/patches/llvm-8-missing-include.patch b/gnu/packages/patches/llvm-8-missing-include.patch
new file mode 100644
index 0000000000..4d7ca6d332
--- /dev/null
+++ b/gnu/packages/patches/llvm-8-missing-include.patch
@@ -0,0 +1,17 @@
+Add missing include statement for compatibility with libstdc++ 11.
+
+Taken from upstream:
+
+  https://github.com/llvm/llvm-project/commit/b498303066a63a203d24f739b2d2e0e56dca70d1
+
+diff --git a/utils/benchmark/src/benchmark_register.h b/utils/benchmark/src/benchmark_register.h
+--- a/utils/benchmark/src/benchmark_register.h
++++ b/utils/benchmark/src/benchmark_register.h
+@@ -1,6 +1,7 @@
+ #ifndef BENCHMARK_REGISTER_H
+ #define BENCHMARK_REGISTER_H
+ 
++#include <limits>
+ #include <vector>
+ 
+ #include "check.h"
-- 
cgit v1.2.3