From f19e571c970ee40902bab1fea3c8654a73caf02f Mon Sep 17 00:00:00 2001
From: Marius Bakke <mbakke@fastmail.com>
Date: Sat, 19 Oct 2019 18:43:11 +0200
Subject: gnu: kodi: Increase test timeout.

* gnu/packages/patches/kodi-increase-test-timeout.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/kodi.scm (kodi)[source](patches): Add it.
---
 gnu/packages/patches/kodi-increase-test-timeout.patch | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)
 create mode 100644 gnu/packages/patches/kodi-increase-test-timeout.patch

(limited to 'gnu/packages/patches/kodi-increase-test-timeout.patch')

diff --git a/gnu/packages/patches/kodi-increase-test-timeout.patch b/gnu/packages/patches/kodi-increase-test-timeout.patch
new file mode 100644
index 0000000000..8fb149ff9d
--- /dev/null
+++ b/gnu/packages/patches/kodi-increase-test-timeout.patch
@@ -0,0 +1,18 @@
+Increase thread timeout to reduce flakiness.
+
+Taken from upstream:
+https://github.com/xbmc/xbmc/commit/574b0182d8b641fd24029f372ebdcccc897123e2
+
+diff --git a/xbmc/threads/test/TestEvent.cpp b/xbmc/threads/test/TestEvent.cpp
+index 42fb8c2fc609..40e644c0ed3c 100644
+--- a/xbmc/threads/test/TestEvent.cpp
++++ b/xbmc/threads/test/TestEvent.cpp
+@@ -484,7 +484,7 @@ TEST(TestEvent, GroupTimedWait)
+   EXPECT_TRUE(w3.result == NULL);
+ 
+   // this should end given the wait is for only 50 millis
+-  EXPECT_TRUE(waitThread3.timed_join(MILLIS(100)));
++  EXPECT_TRUE(waitThread3.timed_join(MILLIS(200)));
+ 
+   EXPECT_TRUE(!w3.waiting);
+   EXPECT_TRUE(w3.result == NULL);
-- 
cgit v1.2.3