From 6d0368eb842f4b5b8a65209569a21c07b378b397 Mon Sep 17 00:00:00 2001
From: Julien Lepiller <julien@lepiller.eu>
Date: Sat, 18 Nov 2017 22:03:57 +0100
Subject: gnu: Add java-xerces.

* gnu/packages/java.scm (java-xerces): New variable.
* gnu/packages/patches/java-xerces-bootclasspath.patch: New file.
* gnu/packages/patches/java-xerces-build_dont_unzip.patch: New file.
* gnu/packages/patches/java-xerces-xjavac_taskdef.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add them.
---
 .../patches/java-xerces-bootclasspath.patch        | 38 ++++++++++++++++++++++
 1 file changed, 38 insertions(+)
 create mode 100644 gnu/packages/patches/java-xerces-bootclasspath.patch

(limited to 'gnu/packages/patches/java-xerces-bootclasspath.patch')

diff --git a/gnu/packages/patches/java-xerces-bootclasspath.patch b/gnu/packages/patches/java-xerces-bootclasspath.patch
new file mode 100644
index 0000000000..efaa548a62
--- /dev/null
+++ b/gnu/packages/patches/java-xerces-bootclasspath.patch
@@ -0,0 +1,38 @@
+Based on https://anonscm.debian.org/viewvc/pkg-java/trunk/libxerces2-java/debian/patches/03_bootclasspath.patch?revision=14509, adopted for guix
+
+--- xerces-2_11_0/build.xml.orig	2010-11-26 21:42:11.000000000 +0100
++++ xerces-2_11_0/build.xml	2017-03-28 14:04:41.946606996 +0200
+@@ -290,13 +290,14 @@
+            destdir="${build.dest}"
+            source="${javac.source}"
+            target="${javac.target}"
+-           classpath="${build.dir}/classes:${tools.dir}/${jar.apis}:${tools.dir}/${jar.resolver}:${tools.dir}/${jar.serializer}"
++           classpath="${build.dir}/classes:${jar.jaxp}:${jar.apis-ext}:${jar.resolver}"
+            debug="${debug}" nowarn="true"
+            debuglevel="${debuglevel}"
+            deprecation="${deprecation}"
+            optimize="${optimize}"
+            includeAntRuntime="false"
+-           includeJavaRuntime="false"
++           includeJavaRuntime="true"
++           bootclasspath="${jar.jaxp}:${jar.apis-ext}:${jar.resolver}"
+            excludes="org/xml/sax/** 
+                 javax/xml/**
+                 org/w3c/dom/*
+@@ -1451,13 +1452,14 @@
+                destdir="${build.dest}"
+                source="${javac.source}"
+                target="${javac.target}"
+-               classpath="${build.dir}/classes:${tools.dir}/${jar.apis}:${tools.dir}/${jar.resolver}:${tools.dir}/${jar.serializer}"
++               classpath="${build.dir}/classes:${jar.jaxp}:${jar.apis-ext}:${jar.resolver}"
+                debug="${debug}"
+                debuglevel="${debuglevel}"
+                deprecation="${deprecation}"
+                optimize="${optimize}"
+                includeAntRuntime="false"
+-               includeJavaRuntime="false"
++               includeJavaRuntime="true"
++               bootclasspath="${jar.jaxp}:${jar.apis-ext}:${jar.resolver}"
+                excludes="org/xml/sax/** 
+                     javax/xml/**
+                     org/w3c/dom/*
-- 
cgit v1.2.3