From 43bfbf137043c2e86ae907528ab830d66e86c642 Mon Sep 17 00:00:00 2001
From: Eric Bavier <bavier@member.fsf.org>
Date: Sat, 11 Feb 2017 21:23:52 -0600
Subject: gnu: Add hubbub.

* gnu/packages/web.scm (hubbub): New variable.
---
 gnu/packages/patches/hubbub-sort-entities.patch | 13 +++++++++++++
 1 file changed, 13 insertions(+)
 create mode 100644 gnu/packages/patches/hubbub-sort-entities.patch

(limited to 'gnu/packages/patches/hubbub-sort-entities.patch')

diff --git a/gnu/packages/patches/hubbub-sort-entities.patch b/gnu/packages/patches/hubbub-sort-entities.patch
new file mode 100644
index 0000000000..012e3c3022
--- /dev/null
+++ b/gnu/packages/patches/hubbub-sort-entities.patch
@@ -0,0 +1,13 @@
+Traverse the entities hash's keys in sorted order to ensure reproducibility.
+
+--- libhubbub-0.3.3/build/make-entities.pl
++++ libhubbub-0.3.3/build/make-entities.pl
+@@ -86,7 +86,7 @@
+ 
+ my $trie;
+ 
+-foreach my $key (keys %entities) {
++foreach my $key (sort keys %entities) {
+    $trie = insert_node($trie, $key, $entities{$key});
+ }
+ 
-- 
cgit v1.2.3