From 632a001bce31c4286e9ed8f60e665f45b31f7970 Mon Sep 17 00:00:00 2001
From: Efraim Flashner <efraim@flashner.co.il>
Date: Mon, 25 May 2020 09:01:48 +0300
Subject: gnu: enlightenment: Fix screen unlocking.

Without this the password is never collected and checked.

* gnu/packages/patches/enlightenment-fix-setuid-path.patch: Fix patch so
that it collects the entered password.
---
 gnu/packages/patches/enlightenment-fix-setuid-path.patch | 16 +++++++---------
 1 file changed, 7 insertions(+), 9 deletions(-)

(limited to 'gnu/packages/patches/enlightenment-fix-setuid-path.patch')

diff --git a/gnu/packages/patches/enlightenment-fix-setuid-path.patch b/gnu/packages/patches/enlightenment-fix-setuid-path.patch
index f2930845ba..a0efb29857 100644
--- a/gnu/packages/patches/enlightenment-fix-setuid-path.patch
+++ b/gnu/packages/patches/enlightenment-fix-setuid-path.patch
@@ -1,26 +1,24 @@
 diff --git a/src/bin/e_auth.c b/src/bin/e_auth.c
-index 8b0aa6641..f15d2c2a2 100644
+index 8b0aa6641..3dff0ad84 100644
 --- a/src/bin/e_auth.c
 +++ b/src/bin/e_auth.c
-@@ -11,9 +11,7 @@ e_auth_begin(char *passwd)
-    pwlen = strlen(passwd);
+@@ -12,8 +12,7 @@ e_auth_begin(char *passwd)
     if (pwlen == 0) goto out;
  
--   snprintf(buf, sizeof(buf),
+    snprintf(buf, sizeof(buf),
 -            "%s/enlightenment/utils/enlightenment_ckpasswd pw",
 -            e_prefix_lib_get());
-+   snprintf(buf, sizeof(buf), "/run/setuid-programs/enlightenment_ckpasswd");
++            "/run/setuid-programs/enlightenment_ckpasswd pw");
     exe = ecore_exe_pipe_run(buf, ECORE_EXE_PIPE_WRITE, NULL);
     if (!exe) goto out;
     if (ecore_exe_send(exe, passwd, pwlen) != EINA_TRUE) goto out;
-@@ -46,9 +44,7 @@ e_auth_polkit_begin(char *passwd, const char *cookie, unsigned int uid)
-    pwlen = strlen(passwd);
+@@ -47,8 +46,7 @@ e_auth_polkit_begin(char *passwd, const char *cookie, unsigned int uid)
     if (pwlen == 0) goto out;
  
--   snprintf(buf, sizeof(buf),
+    snprintf(buf, sizeof(buf),
 -            "%s/enlightenment/utils/enlightenment_ckpasswd pk",
 -            e_prefix_lib_get());
-+   snprintf(buf, sizeof(buf), "/run/setuid-programs/enlightenment_ckpasswd");
++            "/run/setuid-programs/enlightenment_ckpasswd pk");
     exe = ecore_exe_pipe_run(buf, ECORE_EXE_PIPE_WRITE, NULL);
     if (!exe) goto out;
     snprintf(buf, sizeof(buf), "%s %u %s", cookie, uid, passwd);
-- 
cgit v1.2.3