From ddab5244dfa85e5ad73da80c3169fe790387743b Mon Sep 17 00:00:00 2001
From: Greg Hogan <code@greghogan.com>
Date: Sat, 10 Oct 2020 17:47:45 +0000
Subject: gnu: Add aws-c-event-stream.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

* gnu/packages/c.scm (aws-c-event-stream): New variable.
* gnu/packages/patches/aws-c-event-stream-cmake-prefix.patch:
New file.
* gnu/local.mk (dist_patch_DATA): Add it.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
---
 gnu/packages/patches/aws-c-event-stream-cmake-prefix.patch | 13 +++++++++++++
 1 file changed, 13 insertions(+)
 create mode 100644 gnu/packages/patches/aws-c-event-stream-cmake-prefix.patch

(limited to 'gnu/packages/patches/aws-c-event-stream-cmake-prefix.patch')

diff --git a/gnu/packages/patches/aws-c-event-stream-cmake-prefix.patch b/gnu/packages/patches/aws-c-event-stream-cmake-prefix.patch
new file mode 100644
index 0000000000..79655a910b
--- /dev/null
+++ b/gnu/packages/patches/aws-c-event-stream-cmake-prefix.patch
@@ -0,0 +1,13 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -3,6 +3,10 @@
+ cmake_minimum_required (VERSION 3.1)
+ project (aws-c-event-stream C)
+ 
++if (DEFINED ENV{CMAKE_PREFIX_PATH})
++    set(CMAKE_PREFIX_PATH $ENV{CMAKE_PREFIX_PATH})
++endif()
++
+ if (DEFINED CMAKE_PREFIX_PATH)
+     file(TO_CMAKE_PATH "${CMAKE_PREFIX_PATH}" CMAKE_PREFIX_PATH)
+ endif()
-- 
cgit v1.2.3