From cc810a72fb25a1920a117bb9b0fce7d25ab8b33c Mon Sep 17 00:00:00 2001
From: "(" <paren@disroot.org>
Date: Fri, 21 Oct 2022 22:11:31 +0100
Subject: gnu: Add go-github-com-go-task-slim-sprig.

* gnu/packages/golang.scm (go-github-com-go-task-slim-sprig): New
  variable.

Signed-off-by: Raghav Gururajan <rg@raghavgururajan.name>
---
 gnu/packages/golang.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

(limited to 'gnu/packages/golang.scm')

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 4d7a1b2be8..15696eab4a 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7681,6 +7681,34 @@ (define-public go-github-com-masterminds-sprig
 template functions.")
     (license license:expat)))
 
+(define-public go-github-com-go-task-slim-sprig
+  (let ((commit "afa1e2071829e4db655eb448d6c7c16eb0bc5766")
+        (revision "0"))
+    (package
+      (name "go-github-com-go-task-slim-sprig")
+      (version (git-version "2.20.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/go-task/slim-sprig")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1185y8qygv8gb3wpghx5d945wq68j4dbaiffq3h0dh453g4h1w7a"))))
+      (build-system go-build-system)
+      (arguments
+       (list #:import-path "github.com/go-task/slim-sprig"
+             ;; Tests try to access the network.
+             #:tests? #f))
+      (home-page "https://github.com/go-task/slim-sprig")
+      (synopsis "Various useful template functions for Go")
+      (description
+       "Sprig provides over 100 functions that extend the Go template system.
+Slim-Sprig is a fork of Sprig that removes all external dependencies to make
+the library more lightweight.")
+      (license license:expat))))
+
 (define-public go-github-com-bmatcuk-doublestar
   (package
     (name "go-github-com-bmatcuk-doublestar")
-- 
cgit v1.2.3