From 5f9a9945b5747e5ec284f8b116b2e8cc1b9064d7 Mon Sep 17 00:00:00 2001
From: Marius Bakke <mbakke@fastmail.com>
Date: Thu, 16 Aug 2018 17:05:13 +0200
Subject: gnu: vlc: Fix build with recent versions of libx264.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

Fixes <https://bugs.gnu.org/32448>.
Reported by Clément Lassieur <clement@lassieur.org>.

* gnu/packages/video.scm (%vlc-libx264-compat.patch): New variable.
(vlc)[source](patches): New field.
---
 gnu/packages/video.scm | 12 ++++++++++++
 1 file changed, 12 insertions(+)

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 6c10348c1d..8cd08efc72 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -850,6 +850,17 @@ (define-public ffmpegthumbnailer
 videoformats depend on the configuration flags of ffmpeg.")
     (license license:gpl2+)))
 
+;; Fix build with newer x264.
+(define %vlc-libx264-compat.patch
+  (origin
+    (method url-fetch)
+    (uri (string-append "https://git.videolan.org/?p=vlc.git;a=patch;h="
+                        "a8953ba707cca1f2de372ca24513296bcfcdaaa8"))
+    (file-name "vlc-libx264-compat.patch")
+    (sha256
+     (base32
+      "04igckbdp3sbp8vh0ihmhcf3yjyyk9r3cd5dm9mn9j6vipi1dg3g"))))
+
 (define-public vlc
   (package
     (name "vlc")
@@ -860,6 +871,7 @@ (define-public vlc
                    "https://download.videolan.org/pub/videolan/vlc/"
                    (car (string-split version #\-))
                    "/vlc-" version ".tar.xz"))
+             (patches (list %vlc-libx264-compat.patch))
              (sha256
               (base32
                "1p7qvdvg9w4lz8vckzhn6bswfkq3qw7fqkgvwjcskdgc266xx7dw"))))
-- 
cgit v1.2.3