From 2d2e97bd71ac034900e26dd759b106fae0839162 Mon Sep 17 00:00:00 2001
From: Marius Bakke <mbakke@fastmail.com>
Date: Thu, 31 Aug 2017 03:24:41 +0200
Subject: gnu: vlc: Fix build and clean up expression.

Commit 3e0c54bf4de0b5e9d77271613287457dbcd64103 touches 'configure.ac' which
in turn regenerates 'po/Makefile.in.in' with the wrong SHELL and breaks
install.  While at it, consolidate the other patching phases and remove
unneeded inputs.

* gnu/packages/video.scm (vlc)[arguments]: Consolidate patching phases into a
'patch-source' phase and run it immediately after unpack.
[native-inputs]: Remove AUTOCONF, AUTOMAKE and LIBTOOL.
---
 gnu/packages/video.scm | 29 ++++++++++-------------------
 1 file changed, 10 insertions(+), 19 deletions(-)

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 07e66d7ecc..068c2ac79d 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -780,10 +780,7 @@ (define-public vlc
                "1a22b913p2227ljz89c4fgjlyln5gcz8z58w32r0wh4srnnd60y4"))))
     (build-system gnu-build-system)
     (native-inputs
-     `(("autoconf" ,autoconf)
-       ("automake" ,automake)
-       ("git" ,git) ; needed for a test
-       ("libtool" ,libtool)
+     `(("git" ,git) ; needed for a test
        ("pkg-config" ,pkg-config)))
     ;; FIXME: Add optional inputs once available.
     (inputs
@@ -835,26 +832,20 @@ (define-public vlc
 
        #:phases
        (modify-phases %standard-phases
-         (add-before 'configure 'fix-livemedia-utils-prefix
+         (add-after 'unpack 'patch-source
            (lambda* (#:key inputs #:allow-other-keys)
              (let ((livemedia-utils (assoc-ref inputs "livemedia-utils")))
-               (substitute* "configure.ac"
+               (substitute* "configure"
                  (("LIVE555_PREFIX=\\$\\{LIVE555_PREFIX-\"/usr\"\\}")
                   (string-append "LIVE555_PREFIX=" livemedia-utils)))
+               ;; Some of the tests require using the display to test out VLC,
+               ;; which fails in our sandboxed build system
+               (substitute* "test/run_vlc.sh"
+                 (("./vlc --ignore-config") "echo"))
+               ;; XXX Likely not needed for >2.2.6.
+               (substitute* "modules/gui/qt4/components/interface_widgets.cpp"
+                 (("<qx11info_x11.h>") "<QtX11Extras/qx11info_x11.h>"))
                #t)))
-         (add-before 'configure 'remove-visual-tests
-           ;; Some of the tests require using the display to test out VLC,
-           ;; which fails in our sandboxed build system
-           (lambda _
-             (substitute* "test/run_vlc.sh"
-                          (("./vlc --ignore-config") "echo"))
-             #t))
-         (add-before 'build 'fix-qt-include
-           (lambda _
-             ;; XXX Likely not needed for >2.2.6.
-             (substitute* "modules/gui/qt4/components/interface_widgets.cpp"
-               (("<qx11info_x11.h>") "<QtX11Extras/qx11info_x11.h>"))
-             #t))
          (add-after 'install 'regenerate-plugin-cache
            (lambda* (#:key outputs #:allow-other-keys)
              ;; The 'install-exec-hook' rule in the top-level Makefile.am
-- 
cgit v1.2.3