From 0390a5206381e3d54f27ae46533fa38283927a4d Mon Sep 17 00:00:00 2001
From: Andreas Enge <andreas@enge.fr>
Date: Sun, 17 May 2015 10:04:37 +0200
Subject: gnu: redland: Propagate input.

* gnu/packages/rdf.scm (redland): Move rasqal from 'inputs' to
  'propagated-inputs'.
* gnu/packages/rdf.scm (soprano): Drop input rasqal.
* gnu/packages/audio.scm (ardour-3): Drop inputs rasqal and raptor2.

Reported by John Darrington <jmd@gnu.org>.
---
 gnu/packages/audio.scm | 3 +--
 gnu/packages/rdf.scm   | 6 +++---
 2 files changed, 4 insertions(+), 5 deletions(-)

diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index e15381b68a..e607d1a9a0 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
+;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -208,8 +209,6 @@ (define-public ardour-3
        ("sratom" ,sratom)
        ("suil" ,suil)
        ("lilv" ,lilv)
-       ("rasqal" ,rasqal)
-       ("raptor2" ,raptor2)
        ("redland" ,redland)
        ("rubberband" ,rubberband)
        ("taglib" ,taglib)
diff --git a/gnu/packages/rdf.scm b/gnu/packages/rdf.scm
index f26b021e50..cee7f42398 100644
--- a/gnu/packages/rdf.scm
+++ b/gnu/packages/rdf.scm
@@ -221,9 +221,10 @@ (define-public redland
     (native-inputs
      `(("perl" ,perl) ; needed for installation
        ("pkg-config" ,pkg-config)))
+    (propagated-inputs
+     `(("rasqal" ,rasqal))) ; in Requires.private field of .pc
     (inputs
-     `(("bdb" ,bdb)
-       ("rasqal" ,rasqal)))
+     `(("bdb" ,bdb)))
     (home-page "http://librdf.org/")
     (synopsis "RDF library")
     (description "The Redland RDF Library (librdf) provides the RDF API
@@ -317,7 +318,6 @@ (define-public soprano
     (inputs
      `(("clucene" ,clucene)
        ("qt" ,qt-4)
-       ("rasqal" ,rasqal)
        ("redland" ,redland)))
     (home-page "http://soprano.sourceforge.net/")
     (synopsis "RDF data library for Qt")
-- 
cgit v1.2.3