summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index eaf2bf4900..efd80c14c5 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -19,7 +19,7 @@
;;; Copyright © 2016, 2017, 2018, 2019, 2020 Arun Isaac <[email protected]>
;;; Copyright © 2017 Christopher Baines <[email protected]>
;;; Copyright © 2017, 2018, 2019, 2020 Mathieu Othacehe <[email protected]>
-;;; Copyright © 2017, 2018, 2019, 2020 Clément Lassieur <[email protected]>
+;;; Copyright © 2017, 2018, 2019, 2020, 2021 Clément Lassieur <[email protected]>
;;; Copyright © 2017 Vasile Dumitrascu <[email protected]>
;;; Copyright © 2017, 2018 Kyle Meyer <[email protected]>
;;; Copyright © 2017 Kei Kebreau <[email protected]>
@@ -3851,19 +3851,18 @@ result.")
(arguments
'(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'hardcode-rg-path
- ;; Hardcode the path to ripgrep.
+ (add-after 'unpack 'remove-rg-path
+ ;; Remove the path to ripgrep so that it works on remote systems.
(lambda _
(let ((file "rg.el"))
(chmod file #o644)
(emacs-substitute-sexps file
- ("(defcustom rg-executable" (which "rg")))))))))
+ ("(defcustom rg-executable" "rg"))))))))
(propagated-inputs
`(("emacs-s" ,emacs-s)
("emacs-transient" ,emacs-transient)
- ("emacs-wgrep" ,emacs-wgrep)))
- (inputs
- `(("ripgrep" ,ripgrep)))
+ ("emacs-wgrep" ,emacs-wgrep)
+ ("ripgrep" ,ripgrep)))
(home-page "https://rgel.readthedocs.io/en/latest/")
(synopsis "Search tool based on @code{ripgrep}")
(description