summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm24
1 files changed, 23 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9d115790e1..5a4220541e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -39,7 +39,7 @@
;;; Copyright © 2017 Ben Sturmfels <[email protected]>
;;; Copyright © 2017, 2018, 2019 Mathieu Othacehe <[email protected]>
;;; Copyright © 2017 José Miguel Sánchez García <[email protected]>
-;;; Copyright © 2017, 2020 Roel Janssen <[email protected]>
+;;; Copyright © 2017, 2020, 2021 Roel Janssen <[email protected]>
;;; Copyright © 2017, 2018, 2019 Kei Kebreau <[email protected]>
;;; Copyright © 2017 Rutger Helling <[email protected]>
;;; Copyright © 2017 Muriithi Frederick Muriuki <[email protected]>
@@ -2020,6 +2020,28 @@ information created by most SVG editors. Optimization options are typically
lossless but can be tweaked for more aggressive cleaning.")
(license license:asl2.0)))
+(define-public python-mappy
+ (package
+ (name "python-mappy")
+ (version "2.18")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "mappy" version))
+ (sha256
+ (base32
+ "1a05p7rkmxa6qhm108na8flzj2v45jab06drk59kzk1ip2sgvzqq"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-cython" ,python-cython)))
+ (inputs
+ `(("zlib" ,zlib)))
+ (home-page "https://github.com/lh3/minimap2")
+ (synopsis "Python binding for minimap2")
+ (description "This package provides a convenient interface to minimap2,
+a fast and accurate C program to align genomic and transcribe nucleotide
+sequences.")
+ (license license:expat)))
+
(define-public python-mechanize
(package
(name "python-mechanize")