summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9369cc06a8..a012241dbd 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6244,9 +6244,14 @@ important tasks for becoming a daemon process:
(native-inputs
(list python-hatchling
python-pytest))
+ (propagated-inputs (list python-typing-extensions))
(home-page "https://github.com/annotated-types/annotated-types")
(synopsis "Reusable constraint types to use with typing.Annotated")
- (description "Reusable constraint types to use with typing.Annotated")
+ (description "This package provides metadata objects which can be used to
+represent common constraints such as upper and lower bounds on scalar values and
+collection sizes, a Predicate marker for runtime checks, and descriptions of how
+we intend these metadata to be interpreted. In some cases, we also note
+alternative representations which do not require this package.")
(license license:expat)))
(define-public python-anytree