summaryrefslogtreecommitdiff
path: root/gnu/packages/wireservice.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/wireservice.scm')
-rw-r--r--gnu/packages/wireservice.scm30
1 files changed, 14 insertions, 16 deletions
diff --git a/gnu/packages/wireservice.scm b/gnu/packages/wireservice.scm
index b704111db0..d315bc2d74 100644
--- a/gnu/packages/wireservice.scm
+++ b/gnu/packages/wireservice.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2019 Pierre Langlois <[email protected]>
;;; Copyright © 2020 Tobias Geerinckx-Rice <[email protected]>
;;; Copyright © 2020 Tanguy Le Carrour <[email protected]>
+;;; Copyright © 2022 Guillaume Le Vaillant <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -174,7 +175,7 @@ for dbf files support to all @code{agate.Table} instances.")))
(define-public python-agate-excel
(wireservice-package
(name "python-agate-excel")
- (version "0.2.3")
+ (version "0.2.5")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -183,15 +184,16 @@ for dbf files support to all @code{agate.Table} instances.")))
(file-name (git-file-name name version))
(sha256
(base32
- "1k5lv21k19s7kgbj5srd1xgrkqvxqqs49qwj33zncs9l7851afy7"))))
+ "1y3cw57000inwczx50n16kxkr3xi2l241iml1qcqp29a0ba5c519"))))
(native-inputs
- `(("python-nose" ,python-nose)
- ("python-sphinx" ,python-sphinx)
- ("python-sphinx-rtd-theme" ,python-sphinx-rtd-theme)))
+ (list python-nose
+ python-sphinx
+ python-sphinx-rtd-theme))
(propagated-inputs
- `(("python-agate" ,python-agate)
- ("python-openpyxl" ,python-openpyxl)
- ("python-xlrd" ,python-xlrd)))
+ (list python-agate
+ python-olefile
+ python-openpyxl
+ python-xlrd))
(home-page "https://agate-excel.rtfd.org")
(synopsis "Add read support for Excel files (xls and xlsx) to agate")
(description "@code{agateexcel} uses a monkey patching pattern to add read
@@ -209,15 +211,11 @@ for xls and xlsx files support to all @code{agate.Table} instances.")))
"1ffmbzk4rxnl1yhqfl58v7kvl5m9cbvjm8v7xp4mvr00sgs91lvv"))))
(build-system python-build-system)
(native-inputs
- `(("python-psycopg2" ,python-psycopg2) ; to test PostgreSQL support
- ("python-sphinx" ,python-sphinx)
- ("python-sphinx-rtd-theme" ,python-sphinx-rtd-theme)))
+ (list python-psycopg2 ; to test PostgreSQL support
+ python-sphinx python-sphinx-rtd-theme))
(inputs
- `(("python-agate-dbf" ,python-agate-dbf)
- ("python-agate-excel" ,python-agate-excel)
- ("python-agate-sql" ,python-agate-sql)
- ("python-six" ,python-six)
- ("python-text-unidecode" ,python-text-unidecode)))
+ (list python-agate-dbf python-agate-excel python-agate-sql
+ python-six python-text-unidecode))
(arguments
`(#:phases
(modify-phases %standard-phases