summaryrefslogtreecommitdiff
path: root/gnu/packages/virtualization.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/virtualization.scm')
-rw-r--r--gnu/packages/virtualization.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index 64a26edb02..4fc6f1868c 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013-2017, 2020-2022 Ludovic Courtès <[email protected]>
;;; Copyright © 2015, 2016, 2017, 2018 Mark H Weaver <[email protected]>
-;;; Copyright © 2016, 2017, 2018. 2019, 2020, 2021 Efraim Flashner <[email protected]>
+;;; Copyright © 2016-2021, 2023 Efraim Flashner <[email protected]>
;;; Copyright © 2016, 2017 Ricardo Wurmus <[email protected]>
;;; Copyright © 2017 Alex Vong <[email protected]>
;;; Copyright © 2017 Andy Patterson <[email protected]>
@@ -302,7 +302,11 @@
;; Comment out the test-char test, which needs networking and
;; fails within the build environment.
((".*'test-char':.*" all)
- (string-append "# " all)))))
+ (string-append "# " all)))
+ (substitute* "tests/qtest/meson.build"
+ ;; These tests fail to get the expected number of tests
+ ;; on arm platforms.
+ (("'arm-cpu-features',") ""))))
#$@(if (target-riscv64?)
'((add-after 'unpack 'disable-some-tests
(lambda _
@@ -1188,7 +1192,7 @@ of one or more RISC-V harts.")
(format #f "path = ~s;"
(search-input-directory (or native-inputs inputs)
"share/osinfo")))))))))
- (inputs (list libsoup-minimal-2 libxml2 libxslt osinfo-db))
+ (inputs (list libsoup libxml2 libxslt osinfo-db))
(native-inputs
(list `(,glib "bin") ;glib-mkenums, etc.
gobject-introspection
@@ -2196,7 +2200,7 @@ by default and can be made read-only.")
`(#:tests? #f)) ; no tests exist
(inputs
(list libxrandr))
- (home-page "http://bochs.sourceforge.net/")
+ (home-page "https://bochs.sourceforge.net/")
(synopsis "Emulator for x86 PC")
(description
"Bochs is an emulator which can emulate Intel x86 CPU, common I/O