summaryrefslogtreecommitdiff
path: root/gnu/packages/terminals.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/terminals.scm')
-rw-r--r--gnu/packages/terminals.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index de9bec9e66..85bca58bca 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -27,6 +27,7 @@
;;; Copyright © 2021 Raphaël Mélotte <[email protected]>
;;; Copyright © 2021 ikasero <[email protected]>
;;; Copyright © 2021 Brice Waegeneire <[email protected]>
+;;; Copyright © 2021 Solene Rapenne <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -877,7 +878,8 @@ usable with any list--including files, command history, processes and more.")
(arguments
(ensure-keyword-arguments
(package-arguments go-github-com-junegunn-fzf)
- `(#:phases
+ `(#:install-source? #f
+ #:phases
(modify-phases %standard-phases
(add-after 'install 'copy-binaries
(lambda* (#:key outputs #:allow-other-keys)
@@ -895,11 +897,16 @@ usable with any list--including files, command history, processes and more.")
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(bash-completion (string-append out "/etc/bash_completion.d"))
+ (fish-completion
+ (string-append out "/share/fish/vendor_completions.d"))
(zsh-completion (string-append out "/share/zsh/site-functions")))
(with-directory-excursion "src/github.com/junegunn/fzf"
(mkdir-p bash-completion)
(copy-file "shell/completion.bash"
(string-append bash-completion "/fzf"))
+ (mkdir-p fish-completion)
+ (copy-file "shell/key-bindings.fish"
+ (string-append fish-completion "/fzf.fish"))
(mkdir-p zsh-completion)
(copy-file "shell/completion.zsh"
(string-append zsh-completion "/_fzf"))))))))))