summaryrefslogtreecommitdiff
path: root/gnu/packages/tcl.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/tcl.scm')
-rw-r--r--gnu/packages/tcl.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/tcl.scm b/gnu/packages/tcl.scm
index 2a5fbc6fe8..b69dba2254 100644
--- a/gnu/packages/tcl.scm
+++ b/gnu/packages/tcl.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2014, 2015, 2018 Mark H Weaver <[email protected]>
;;; Copyright © 2014 Eric Bavier <[email protected]>
;;; Copyright © 2016, 2018 Efraim Flashner <[email protected]>
-;;; Copyright © 2016 Jan Nieuwenhuizen <[email protected]>
+;;; Copyright © 2016, 2023 Janneke Nieuwenhuizen <[email protected]>
;;; Copyright © 2017 Kei Kebreau <[email protected]>
;;; Copyright © 2018, 2022 Tobias Geerinckx-Rice <[email protected]>
;;; Copyright © 2019 Julien Lepiller <[email protected]>
@@ -69,7 +69,13 @@
;; Programs such as Ghostscript rely on it.
(with-directory-excursion bin
(symlink (car (find-files "." "tclsh"))
- "tclsh"))))))
+ "tclsh")))))
+ ,@(if (system-hurd?)
+ '((add-after 'unpack 'delete-tests
+ (lambda _
+ (delete-file "tests/chanio.test")
+ (delete-file "tests/socket.test"))))
+ '()))
;; By default, man pages are put in PREFIX/man, but we want them in
;; PREFIX/share/man. The 'validate-documentation-location' phase is