summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm53
1 files changed, 24 insertions, 29 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 141c3d681e..9d9fbcd08f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3938,14 +3938,14 @@ e.g. filters, callbacks and errbacks can all be promises.")
(define-public python-markupsafe
(package
(name "python-markupsafe")
- (version "2.0.1")
+ (version "2.1.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "MarkupSafe" version))
(sha256
(base32
- "02k2ynmqvvd0z0gakkf8s4idyb606r7zgga41jrkhqmigy06fk2r"))))
+ "0jqxp5sfrc0byp6bk0gwdmildi4mck2gprp42afri3z4r5y1k4bz"))))
(build-system python-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
@@ -5461,13 +5461,13 @@ provides additional functionality on the produced Mallard documents.")
(define-public python-cython
(package
(name "python-cython")
- (version "0.29.24")
+ (version "0.29.30")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Cython" version))
(sha256
- (base32 "0hw4gs18rh4slij1fg252argxhraypld9apbqbl60230qc3lvw6d"))))
+ (base32 "1qzrcnla3fg4fmf7ncvxhr1y35gvya1ybj12jjwshvzym0nvcd92"))))
(build-system python-build-system)
;; we need the full python package and not just the python-wrapper
;; because we need libpython3.3m.so
@@ -5607,7 +5607,7 @@ capabilities.")
(package
(inherit python-numpy)
(name "python-numpy-next")
- (version "1.22.3")
+ (version "1.23.1")
(source
(origin
(inherit (package-source python-numpy))
@@ -5617,7 +5617,10 @@ capabilities.")
version "/numpy-" version ".tar.gz"))
(sha256
(base32
- "19dw91pqbqcniw2z57kiyqs1qp56g7kqy1bdyv664g8s62sc01m9"))))))
+ "095nv17vm8hvj8cj0d76syl9xh99bbnkgnjr9ccy3wpykcsfyj6p"))))
+ (native-inputs
+ (modify-inputs (package-native-inputs python-numpy)
+ (append python-typing-extensions)))))
(define-public python-numpy-documentation
(package
@@ -13156,7 +13159,8 @@ time.")
(list python-ipykernel
;; Adding ipywidgets would create a cycle.
;;python-ipywidgets
- ;;python-pyppeteer ;TODO: package me
+ ;; XXX: Disabled, not in guix.
+ ;;python-pyppeteer
python-pytest
python-pytest-xdist))
(propagated-inputs
@@ -13182,14 +13186,14 @@ time.")
texlive-caption
texlive-enumitem
texlive-fontspec
- texlive-generic-iftex
+ texlive-iftex
texlive-grffile
texlive-hyperref
- texlive-latex-fancyvrb
+ texlive-fancyvrb
texlive-latex-float
texlive-latex-geometry
texlive-latex-jknapltx
- texlive-latex-ms
+ texlive-ms
texlive-latex-parskip
texlive-latex-trimspaces
texlive-latex-upquote
@@ -14919,27 +14923,27 @@ of @acronym{REGEXPs, regular expressions}.")
(define-public python-mako
(package
(name "python-mako")
- (version "1.1.3")
+ (version "1.2.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Mako" version))
(sha256
(base32
- "09ywrmhr6gdyfx6d5727wwjnz73i6rklqcb4c14m7sqc830wi5c1"))))
+ "01q3gdqpxqcxdhacrzrwk6fjpd1krdr73i7cm4d2yja38zzsam7h"))))
(build-system python-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(if tests?
- (invoke "nosetests" "-v")
+ (invoke "pytest" "-vv")
(format #t "test suite not run~%"))
#t)))))
(propagated-inputs
(list python-markupsafe))
(native-inputs
- (list python-mock python-nose))
+ (list python-mock python-pytest))
(home-page "https://www.makotemplates.org/")
(synopsis "Templating language for Python")
(description "Mako is a templating language for Python that compiles
@@ -15793,9 +15797,7 @@ syntax highlighting, markdown and more to the terminal.")
(list which))
(inputs
;; python-magic needs to be able to find libmagic.so.
- ;; Use a newer version because 5.39 returns bogus for some archives
- ;; (notably Chromium .crx extensions), which breaks e.g. 'diffoscope'.
- (list file-next))
+ (list file))
(synopsis "File type identification using libmagic")
(description
"This module uses ctypes to access the libmagic file type
@@ -21471,26 +21473,19 @@ with PEP 484 argument (and return) type annotations.")
(define-public python-typing-extensions
(package
(name "python-typing-extensions")
- (version "4.0.1")
+ (version "4.3.0")
(source (origin
- ;; The test script is missing from the PyPI archive.
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/python/typing")
- (commit version)))
- (file-name (git-file-name name version))
+ (method url-fetch)
+ (uri (pypi-uri "typing_extensions" version))
(sha256
(base32
- "0a35fh5wk9s538x0w3dz95y0avnhd2srzyv9s1a372711n8hdl4p"))))
+ "19n4l57qazwrbvxjrbxw2vvfyd0zbk8ivnwm4zmwfzzl69x6glp6"))))
(build-system python-build-system)
(arguments
(list
#:tests? #f ;requires Python's test module, not available in Guix
#:phases
#~(modify-phases %standard-phases
- (add-after 'unpack 'enter-source-directory
- (lambda _
- (chdir "typing_extensions")))
;; XXX: PEP 517 manual build copied from python-isort.
(replace 'build
(lambda _
@@ -26601,7 +26596,7 @@ By default it uses the open Python vulnerability database Safety DB.")
(native-inputs
`(("texlive" ,(texlive-updmap.cfg (list texlive-amsfonts
texlive-fonts-ec
- texlive-generic-iftex
+ texlive-iftex
texlive-hyperref
texlive-oberdiek
texlive-lm