summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 7f8613e9c4..0515f1c9f1 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6182,6 +6182,21 @@ various web frameworks, simply implemented, light on server resources,
and fairly speedy.")
(license license:expat)))
+(define-public gunicorn-next
+ (package
+ (inherit gunicorn)
+ (name "gunicorn")
+ (version "22.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "gunicorn" version))
+ (sha256
+ (base32
+ "0qzc3ghayc137hlwrqqwkkhaf8f5h9ja21qwy4rznxpz75i462sa"))))
+ ;; CVE-2024-1135 is fixed in version 22.0.0.
+ (properties `((lint-hidden-cve . ("CVE-2024-1135"))))))
+
;; break cyclic dependency for python-aiohttp, which depends on gunicorn for
;; its tests
(define-public gunicorn-bootstrap