summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm78
1 files changed, 53 insertions, 25 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 32b4aa4bf0..ce0e0a605c 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -43,6 +43,7 @@
;;; Copyright © 2021 Ekaitz Zarraga <[email protected]>
;;; Copyright © 2021 Greg Hogan <[email protected]>
;;; Copyright © 2021 Maxime Devos <[email protected]>
+;;; Copyright © 2021 Pradana Aumars <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -375,13 +376,13 @@ WSGI. This package includes libraries for implementing ASGI servers.")
(define-public python-aws-sam-translator
(package
(name "python-aws-sam-translator")
- (version "1.36.0")
+ (version "1.38.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "aws-sam-translator" version))
(sha256
(base32
- "115mcbb4r205c1hln199llqrvvbijfqz075rwx991l99jc6rj6zs"))))
+ "1djwlsjpbh13m4biglimrm9lq7hmla0k29giay7k3cjsrylxvjhf"))))
(build-system python-build-system)
(arguments
`(;; XXX: Tests are not distributed with the PyPI archive, and would
@@ -478,7 +479,7 @@ emit information from within their applications to the AWS X-Ray service.")
(define-public python-cfn-lint
(package
(name "python-cfn-lint")
- (version "0.51.0")
+ (version "0.54.1")
(home-page "https://github.com/aws-cloudformation/cfn-python-lint")
(source (origin
(method git-fetch)
@@ -488,7 +489,7 @@ emit information from within their applications to the AWS X-Ray service.")
(file-name (git-file-name name version))
(sha256
(base32
- "1027s243sik25c6sqw6gla7k7vl3jdicrik5zdsa8pafxh2baja4"))))
+ "161mzzlpbi85q43kwzrj39qb32l6wg6xhnbbd4z860yrfbymsn87"))))
(build-system python-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
@@ -506,7 +507,7 @@ emit information from within their applications to the AWS X-Ray service.")
(getenv "PYTHONPATH")))
(setenv "PATH" (string-append out "/bin:"
(getenv "PATH")))
- (invoke "python" "-m" "unittest" "discover"
+ (invoke "python" "-m" "unittest" "discover" "-v"
"-s" "test")))))))
(native-inputs
`(("python-pydot" ,python-pydot)
@@ -2818,14 +2819,14 @@ supports url redirection and retries, and also gzip and deflate decoding.")
(define python-urllib3/fixed
(package
(inherit python-urllib3)
- (version "1.26.4")
+ (version "1.26.7")
(source
(origin
(method url-fetch)
(uri (pypi-uri "urllib3" version))
(sha256
(base32
- "0dw9w9bs3hmr5dp3r3h43jyzzb1g1046ag7lj8pqf58i4kvj3c77"))))))
+ "1kkf6gi8a1fs0dqkf6kpmdpsy97iirvliz8q1krxp8ppaiawd1s9"))))))
;; Some software requires an older version of urllib3, notably Docker.
(define-public python-urllib3-1.24
@@ -2838,7 +2839,6 @@ supports url redirection and retries, and also gzip and deflate decoding.")
(base32
"1x0slqrv6kixkbcdnxbglvjliwhc1payavxjvk8fvbqjrnasd4r3"))))))
-
(define-public python2-urllib3
(let ((base (package-with-python2 (strip-python2-variant python-urllib3))))
(package/inherit
@@ -3550,13 +3550,13 @@ applications.")
(define-public python-flask-sqlalchemy
(package
(name "python-flask-sqlalchemy")
- (version "2.4.4")
+ (version "2.5.1")
(source (origin
(method url-fetch)
(uri (pypi-uri "Flask-SQLAlchemy" version))
(sha256
(base32
- "1rgsj49gnx361hnb3vn6c1h17497qh22yc3r70l1r6w0mw71bixz"))))
+ "04jrx4sjrz1b20j38qk4qin975xwz30krzq59rfv3b3w7ss49nib"))))
(build-system python-build-system)
(propagated-inputs
`(("python-flask" ,python-flask)
@@ -4150,28 +4150,37 @@ addon modules.")
(define-public python-wtforms
(package
(name "python-wtforms")
- (version "2.1")
+ (version "2.3.3")
(source
(origin
(method url-fetch)
- (uri (pypi-uri "WTForms" version ".zip"))
+ (uri (pypi-uri "WTForms" version))
(sha256
(base32
- "0vyl26y9cg409cfyj8rhqxazsdnd0jipgjw06civhrd53yyi1pzz"))))
+ "17427m7p9nn9byzva697dkykykwcp2br3bxvi8vciywlmkh5s6c1"))))
(build-system python-build-system)
(arguments
- '(#:phases
+ `(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'remove-django-test
- ;; Don't fail the tests when the inputs for the optional tests cannot be found.
+ (add-after 'unpack 'delete-bundled-test
(lambda _
- (substitute*
- "tests/runtests.py"
- (("'ext_django.tests', 'ext_sqlalchemy', 'ext_dateutil', 'locale_babel'") "")
- (("sys.stderr.write(\"### Disabled test '%s', dependency not found\n\" % name)") ""))
- #t)))))
+ ;; Delete test copied from a third party package that fails
+ ;; with newer SQLAlchemy. This can be removed for 3.0.
+ ;; See <https://github.com/wtforms/wtforms/issues/696>.
+ (delete-file "tests/ext_sqlalchemy.py")))
+ (replace 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "python" "setup.py" "compile_catalog")
+ (invoke "python" "tests/runtests.py")))))))
(native-inputs
- `(("unzip" ,unzip)))
+ `(("python-dateutil" ,python-dateutil)
+ ("python-sqlalchemy" ,python-sqlalchemy)))
+ (propagated-inputs
+ `(("python-babel" ,python-babel)
+ ("python-email-validator" ,python-email-validator)
+ ("python-markupsafe" ,python-markupsafe)))
(home-page "http://wtforms.simplecodes.com/")
(synopsis
"Form validation and rendering library for Python web development")
@@ -4181,9 +4190,6 @@ for Python web development. It is very similar to the web form API
available in Django, but is a standalone package.")
(license license:bsd-3)))
-(define-public python2-wtforms
- (package-with-python2 python-wtforms))
-
(define-public python-paste
(package
(name "python-paste")
@@ -6205,3 +6211,25 @@ your code non-blocking and speedy.")
"This project provides a client library in Python that makes it easy to
communicate with Microsoft Azure Storage services.")
(license license:expat)))
+
+(define-public python-w3lib
+ (package
+ (name "python-w3lib")
+ (version "1.22.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "w3lib" version))
+ (sha256
+ (base32
+ "1pv02lvvmgz2qb61vz1jkjc04fgm4hpfvaj5zm4i3mjp64hd1mha"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-six" ,python-six)))
+ (home-page "https://github.com/scrapy/w3lib")
+ (synopsis "Python library of web-related functions")
+ (description
+ "This is a Python library of web-related functions, such as: remove comments,
+or tags from HTML snippets, extract base url from HTML snippets, translate entites
+on HTML strings, among other things.")
+ (license license:bsd-3)))