summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm23
1 files changed, 15 insertions, 8 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 482305de35..28c683ea83 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -4,7 +4,7 @@
;;; Copyright © 2015 Mark H Weaver <[email protected]>
;;; Copyright © 2015, 2016, 2017 Stefan Reichör <[email protected]>
;;; Copyright © 2016 Raimon Grau <[email protected]>
-;;; Copyright © 2016, 2017, 2018, 2019 Tobias Geerinckx-Rice <[email protected]>
+;;; Copyright © 2016, 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <[email protected]>
;;; Copyright © 2016 John Darrington <[email protected]>
;;; Copyright © 2016, 2017, 2018, 2019 Nicolas Goaziou <[email protected]>
;;; Copyright © 2016 Eric Bavier <[email protected]>
@@ -14,7 +14,7 @@
;;; Copyright © 2016, 2017 Pjotr Prins <[email protected]>
;;; Copyright © 2017 Mathieu Othacehe <[email protected]>
;;; Copyright © 2017 Leo Famulari <[email protected]>
-;;; Copyright © 2017, 2018, 2019 Efraim Flashner <[email protected]>
+;;; Copyright © 2017, 2018, 2019, 2020 Efraim Flashner <[email protected]>
;;; Copyright © 2017, 2018, 2019 Rutger Helling <[email protected]>
;;; Copyright © 2017, 2019 Gábor Boskovits <[email protected]>
;;; Copyright © 2017 Thomas Danckaert <[email protected]>
@@ -24,7 +24,7 @@
;;; Copyright © 2018 Clément Lassieur <[email protected]>
;;; Copyright © 2018 Theodoros Foradis <[email protected]>
;;; Copyright © 2018 Marius Bakke <[email protected]>
-;;; Copyright © 2018 Oleg Pykhalov <[email protected]>
+;;; Copyright © 2018, 2020 Oleg Pykhalov <[email protected]>
;;; Copyright © 2018 Pierre Neidhardt <[email protected]>
;;; Copyright © 2019 Maxim Cournoyer <[email protected]>
;;; Copyright © 2019 Vasile Dumitrascu <[email protected]>
@@ -559,15 +559,14 @@ and up to 1 Mbit/s downstream.")
(define-public whois
(package
(name "whois")
- (version "5.5.3")
+ (version "5.5.4")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://debian/pool/main/w/whois/"
"whois_" version ".tar.xz"))
(sha256
- (base32
- "0imb87iz17a530fg1x9wnsm4bvr61hxydv29chfwzh015af3zhsm"))))
+ (base32 "0k97aiz7ngkjz3vhzvk27kqhnmqmkskdfx310c94qnh8fd7hiqfi"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no test suite
@@ -1238,6 +1237,14 @@ It is intended primarily for use in testing.")
(base32
"0ln5f57vc8388kyh9vhx2infrdzfhbpgyby74h1qsnhwds95m0vh"))))
(build-system perl-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'dont-link-with-nsl ; Borrowed from Debian.
+ (lambda _
+ (substitute* "Makefile.PL"
+ (("-lnsl") ""))
+ #t)))))
(inputs
`(("perl-net-cidr-lite" ,perl-net-cidr-lite)
("perl-socket6" ,perl-socket6)))
@@ -1491,14 +1498,14 @@ that block port 22.")
(define-public iperf
(package
(name "iperf")
- (version "3.1.7")
+ (version "3.7")
(source (origin
(method url-fetch)
(uri (string-append "http://downloads.es.net/pub/iperf"
"/iperf-" version ".tar.gz"))
(sha256
(base32
- "0kvk8d0a3dcxc8fisyprbn01y8akxj4sx8ld5dh508p9dx077vx4"))))
+ "033is7b5grfbiil98jxlz4ixp9shm44x6hy8flpsyz1i4h108inq"))))
(build-system gnu-build-system)
(synopsis "TCP, UDP and SCTP bandwidth measurement tool")
(description