summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm8
1 files changed, 2 insertions, 6 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index f6df3ef824..50af7bc396 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2016 Federico Beffa <[email protected]>
;;; Copyright © 2016, 2017 Nikita <[email protected]>
;;; Copyright © 2016, 2017 Andy Patterson <[email protected]>
-;;; Copyright © 2017, 2019 Ricardo Wurmus <[email protected]>
+;;; Copyright © 2017, 2019, 2020 Ricardo Wurmus <[email protected]>
;;; Copyright © 2017, 2018, 2019 Efraim Flashner <[email protected]>
;;; Copyright © 2017, 2019–2021 Tobias Geerinckx-Rice <[email protected]>
;;; Copyright © 2018 Benjamin Slade <[email protected]>
@@ -441,7 +441,7 @@ an interpreter, a compiler, a debugger, and much more.")
("ed" ,ed)
("inetutils" ,inetutils) ;for hostname(1)
("texinfo" ,texinfo)
- ("texlive" ,(texlive-union (list texlive-tex-texinfo)))
+ ("texlive" ,(texlive-updmap.cfg (list texlive-tex-texinfo)))
("which" ,which)
("zlib" ,zlib)))
(arguments
@@ -513,10 +513,6 @@ an interpreter, a compiler, a debugger, and much more.")
(("\\(deftest grent\\.[12]" all)
(string-append "#+nil ;disabled by Guix\n" all))))
#t))
- ;; FIXME: the texlive-union insists on regenerating fonts. It stores
- ;; them in HOME, so it needs to be writeable.
- (add-before 'build 'set-HOME
- (lambda _ (setenv "HOME" "/tmp") #t))
(replace 'build
(lambda* (#:key outputs #:allow-other-keys)
(setenv "CC" "gcc")