summaryrefslogtreecommitdiff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm113
1 files changed, 100 insertions, 13 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 9b6a647f25..02131f10d0 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015 Ricardo Wurmus <[email protected]>
+;;; Copyright © 2015, 2016 Ricardo Wurmus <[email protected]>
;;; Copyright © 2016 Leo Famulari <[email protected]>
;;;
;;; This file is part of GNU Guix.
@@ -51,9 +51,9 @@
#:use-module (gnu packages texinfo)
#:use-module ((srfi srfi-1) #:select (fold alist-delete)))
-(define-public swt
+(define-public java-swt
(package
- (name "swt")
+ (name "java-swt")
(version "4.4.2")
(source (origin
(method url-fetch)
@@ -577,7 +577,7 @@ build process and its dependencies, whereas Make uses Makefile format.")
(license license:gpl2+)))
(define-public icedtea-7
- (let* ((version "2.6.4")
+ (let* ((version "2.6.5")
(drop (lambda (name hash)
(origin
(method url-fetch)
@@ -594,7 +594,7 @@ build process and its dependencies, whereas Make uses Makefile format.")
version ".tar.xz"))
(sha256
(base32
- "0r31h8nlsrbfdkgbjbb7phwgcwglc9siznzrr40lqnm9xrgkc2nj"))
+ "1xskigsa1i8hycbagb0f6idyb16x8dkixcdyaacsw4dvjr230lp7"))
(modules '((guix build utils)))
(snippet
'(substitute* "Makefile.in"
@@ -669,6 +669,8 @@ build process and its dependencies, whereas Make uses Makefile format.")
(setenv "CC" "gcc")
(setenv "CPATH"
(string-append gcjinclude ":"
+ (assoc-ref inputs "libxcomposite")
+ "/include/X11/extensions" ":"
(assoc-ref inputs "libxrender")
"/include/X11/extensions" ":"
(assoc-ref inputs "libxtst")
@@ -719,26 +721,111 @@ build process and its dependencies, whereas Make uses Makefile format.")
(native-inputs
`(("openjdk-src"
,(drop "openjdk"
- "1qjjf71nq80ac2d08hbaa8589d31vk313z3rkirnwq5df8cyf0mv"))
+ "1nxb8b0p1v57ix8gp22ifg9vg0p0lhr59g5vi74f7abg3almcvy6"))
("corba-drop"
,(drop "corba"
- "025warxhjal3nr7w1xyd16k0f32fwkchifpaslzyidsga3hgmfr6"))
+ "0zz7gz8fq7qnifzm2jgir2i6rcp0d2h32lcxvlfs24w5szynjya2"))
("jaxp-drop"
,(drop "jaxp"
- "0qiz6swb78w9c0mf88pf0gflgm5rp9k0l6fv6sdl7dki691b0z09"))
+ "0ym3bcril6507bpbw5mkkw0zmfg3s1nkbsvs2lg0c1q8kyyf3dbv"))
("jaxws-drop"
,(drop "jaxws"
- "18fz4gl4fdlcmqvh1mlpd9h0gj0qizpfa7njkax97aysmsm08xns"))
+ "1l16x4dwhgfpnk32xbigb1kzkvgj0b6zzhdg4rpkywa7gvg9lxaf"))
("jdk-drop"
,(drop "jdk"
- "0qsx5d9pgwlz9vbpapw4jwpajqc6rwk1150cjb33i4n3z709jccx"))
+ "1fi18ji83d0dqzg35kcm4bksg2z3fbg772p05wgw4rhh7dai0f6d"))
("langtools-drop"
,(drop "langtools"
- "1k6plx96smf86z303gb30hncssa8f40qdryzsdv349iwqwacxc7r"))
+ "1nbqg8sw7z7f3bhxng0xdp8vl2nc5wqz0xii1j566qdgc1n6fv3c"))
("hotspot-drop"
,(drop "hotspot"
- "0r9ffzyf5vxs8wg732szqcil0ksc8lcxzihdv3viz7d67dy42irp"))
+ "1z0w8h1jjvxlqzlrwasy323fygx90if09rvqjk4ymaqhzcr35623"))
,@(fold alist-delete (package-native-inputs icedtea-6)
- '("openjdk6-src")))))))
+ '("openjdk6-src"))))
+ (inputs
+ `(("libxcomposite" ,libxcomposite)
+ ,@(package-inputs icedtea-6))))))
+
+(define-public icedtea-8
+ (let* ((version "3.0.0")
+ (drop (lambda (name hash)
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://icedtea.classpath.org/download/drops/"
+ "/icedtea8/" version "/" name ".tar.xz"))
+ (sha256 (base32 hash))))))
+ (package (inherit icedtea-7)
+ (version "3.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://icedtea.wildebeest.org/download/source/icedtea-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "1a99hvx5d0dcinlixgy0wzv2f7jnzi8jp7hcrf2pd7dqndlxsyll"))
+ (modules '((guix build utils)))
+ (snippet
+ '(substitute* "Makefile.am"
+ ;; do not leak information about the build host
+ (("DISTRIBUTION_ID=\"\\$\\(DIST_ID\\)\"")
+ "DISTRIBUTION_ID=\"\\\"guix\\\"\"")))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments icedtea-7)
+ ((#:configure-flags flags)
+ `(let ((jdk (assoc-ref %build-inputs "jdk")))
+ `(;;"--disable-bootstrap"
+ "--enable-bootstrap"
+ "--enable-nss"
+ "--disable-downloading"
+ "--disable-tests" ;they are run in the check phase instead
+ "--with-openjdk-src-dir=./openjdk.src"
+ ,(string-append "--with-jdk-home=" jdk))))
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (delete 'fix-x11-extension-include-path)
+ (delete 'patch-paths)
+ (delete 'set-additional-paths)
+ (delete 'patch-patches)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((doc (string-append (assoc-ref outputs "doc")
+ "/share/doc/icedtea"))
+ (jre (assoc-ref outputs "out"))
+ (jdk (assoc-ref outputs "jdk")))
+ (copy-recursively "openjdk.build/docs" doc)
+ (copy-recursively "openjdk.build/images/j2re-image" jre)
+ (copy-recursively "openjdk.build/images/j2sdk-image" jdk)
+ #t)))))))
+ (native-inputs
+ `(("jdk" ,icedtea-7 "jdk")
+ ("openjdk-src"
+ ,(drop "openjdk"
+ "0cchcrkj3pbjw3r6w08d8fkcjp98fyqp15bv88ljakjcsxrjc0sv"))
+ ("corba-drop"
+ ,(drop "corba"
+ "1k5khy8g0bk8yas81infh4l8rradpslzs0bblri0aqn9s3aq0x6p"))
+ ("jaxp-drop"
+ ,(drop "jaxp"
+ "1s167lwh1bxkjmbcyk1pb9r919hfbjgh2shig3d1qmj24r2fbk2c"))
+ ("jaxws-drop"
+ ,(drop "jaxws"
+ "0xphl8127in0634401f8v3b42mh14v1zdzd7ar10h9m5m84hcmgg"))
+ ("jdk-drop"
+ ,(drop "jdk"
+ "1kdi5v0vf7swkh2r4isdibw8zzsp34d1aa1sbxl5ljc9lfmbhx7s"))
+ ("langtools-drop"
+ ,(drop "langtools"
+ "11pa0sr4yi0nnfwhz25410zimc3jm367cvrhg5jm0xc5rykydq70"))
+ ("hotspot-drop"
+ ,(drop "hotspot"
+ "1my0g9snpd6619y82b4m96wc7ncvf1hw5yqrbh3n1pjgm2k7ywbn"))
+ ("nashorn-drop"
+ ,(drop "nashorn"
+ "1h12a61q3bw8zabhpp6aawfg3pwixjcya64595rj07sid619vidl"))
+ ,@(fold alist-delete (package-native-inputs icedtea-7)
+ '("gcj" "openjdk-src" "corba-drop" "jaxp-drop" "jaxws-drop"
+ "jdk-drop" "langtools-drop" "hotspot-drop")))))))
(define-public icedtea icedtea-7)