summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index e42adbf56a..7fcbb27485 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2020, 2021 raingloom <[email protected]>
;;; Copyright © 2021 Collin J. Doering <[email protected]>
;;; Copyright © 2021 Guillaume Le Vaillant <[email protected]>
+;;; Copyright © 2021 Guix Together <[email protected]>
;;; Copyright © 2021 Raghav Gururajan <[email protected]>
;;; Copyright © 2021 Ricardo Wurmus <[email protected]>
;;; Copyright © 2021 Sarah Morgensen <[email protected]>
@@ -4481,6 +4482,39 @@ Authentication Modules, PAM} application API.")
"This package provides a cancelable reader for Go.")
(license license:expat)))
+(define-public go-github-com-muesli-termenv
+ (package
+ (name "go-github-com-muesli-termenv")
+ (version "0.15.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/muesli/termenv")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "19yhli6k79aqpra4djp0cl4q76mqxbc1f7in20y0dzhnjb7yz42p"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/muesli/termenv"))
+ (propagated-inputs
+ (list go-github-com-aymanbagabas-go-osc52-v2
+ go-github-com-lucasb-eyer-go-colorful
+ go-github-com-mattn-go-isatty
+ go-github-com-mattn-go-runewidth
+ go-golang-org-x-sys))
+ (home-page "https://github.com/muesli/termenv/")
+ (synopsis "Advanced styling options on the terminal")
+ (description
+ "termenv lets you safely use advanced styling options on the terminal.
+It gathers information about the terminal environment in terms of its ANSI and
+color support and offers you convenient methods to colorize and style your
+output, without you having to deal with all kinds of weird ANSI escape
+sequences and color conversions.")
+ (license license:expat)))
+
(define-public go-github-com-multiformats-go-base32
(package
(name "go-github-com-multiformats-go-base32")