summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 0f7d462816..4bdcc05c47 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -85,6 +85,32 @@
;;; Libraries:
;;;
+(define-public go-atomicgo-dev-cursor
+ (package
+ (name "go-atomicgo-dev-cursor")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/atomicgo/cursor")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ds85nyd3dnjr961x9g5kflx1qdb92vn7n6wc4jbk0fjjzbrnh5s"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "atomicgo.dev/cursor"))
+ (home-page "https://atomicgo.dev/cursor")
+ (synopsis "Moving terminal cursor in Golang")
+ (description
+ "Package cursor contains cross-platform methods to move the terminal cursor in
+different directions. This package can be used to create interactive CLI tools
+and games, live charts, algorithm visualizations and other updatable output of
+any kind.")
+ (license license:expat)))
+
(define-public go-bazil-org-fuse
(package
(name "go-bazil-org-fuse")