summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 1155affd3d..86964c47b9 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -508,6 +508,34 @@ syntax highlighted HTML, ANSI-coloured text, etc.")
(list go-github-com-alecthomas-assert-v2
go-github-com-alecthomas-repr))))
+(define-public go-github-com-alecthomas-colour
+ (package
+ (name "go-github-com-alecthomas-colour")
+ (version "0.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alecthomas/colour")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "10zbm12j40ppia4b5ql2blmsps5jhh5d7ffphxx843qk7wlbqnjb"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/alecthomas/colour"))
+ (native-inputs
+ (list go-github-com-mattn-go-isatty))
+ (home-page "https://github.com/alecthomas/colour/")
+ (synopsis "Colour terminal text for Go")
+ (description
+ "Package colour provides Quake-style colour formatting for Unix
+terminals. The package level functions can be used to write to stdout (or
+strings or other files). If stdout is not a terminal, colour formatting will
+be stripped.")
+ (license license:expat)))
+
(define-public go-github-com-alecthomas-kingpin
(package
(name "go-github-com-alecthomas-kingpin")