summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 90d7323e21..36bf7fe0cd 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1278,6 +1278,29 @@ used like a user interface for humans, to read and edit before passing the
JSON data to the machine.")
(license license:expat)))
+(define-public go-github-com-jackpal-gateway
+ (package
+ (name "go-github-com-jackpal-gateway")
+ (version "1.0.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jackpal/gateway")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1yms2dw4dnz4cvj9vhwh6193d50jhvn5awsp2g3a4lcc3sjrgd6m"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/jackpal/gateway"))
+ (home-page "https://github.com/jackpal/gateway")
+ (synopsis "Discover the address of a LAN gateway")
+ (description "@code{gateway} is a Go library for discovering the IP
+address of the default LAN gateway.")
+ (license license:bsd-3)))
+
(define-public go-github-com-jackpal-go-nat-pmp
(package
(name "go-github-com-jackpal-go-nat-pmp")