summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-crypto.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang-crypto.scm')
-rw-r--r--gnu/packages/golang-crypto.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index 22593aff19..eac4fc8139 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2019, 2020 Leo Famulari <[email protected]>
;;; Copyright © 2021 Raghav Gururajan <[email protected]>
;;; Copyright © 2022 Nicolas Graves <[email protected]>
+;;; Copyright © 2023 Artyom V. Poptsov <[email protected]>
;;; Copyright © 2023 Clément Lassieur <[email protected]>
;;;
;;; This file is part of GNU Guix.
@@ -255,6 +256,33 @@ the Go standard library's TLS 1.3 implementation.")
(description "Multihash implementation in Go.")
(license license:expat))))
+(define-public go-github-com-quic-go-qtls-go1-20
+ (package
+ (name "go-github-com-quic-go-qtls-go1-20")
+ (version "0.3.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/quic-go/qtls-go1-20")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0fl3yv1w8cygag3lav45vvzb4k9i72p92x13wcq0xn13wxirzirn"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/quic-go/qtls-go1-20"
+ #:go go-1.20))
+ (propagated-inputs
+ (list go-golang-org-x-crypto
+ go-golang-org-x-sys))
+ (home-page "https://github.com/quic-go/qtls-go1-20")
+ (synopsis "TLS 1.3 for QUIC")
+ (description "Go standard library TLS 1.3 implementation, modified for
+QUIC. For Go 1.20.")
+ (license license:expat)))
+
(define-public go-github-com-refraction-networking-utls
(package
(name "go-github-com-refraction-networking-utls")