summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm42
1 files changed, 37 insertions, 5 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 0f33880a21..535913bcf1 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Andreas Enge <[email protected]>
-;;; Copyright © 2014 Ludovic Courtès <[email protected]>
+;;; Copyright © 2013, 2015 Andreas Enge <[email protected]>
+;;; Copyright © 2014, 2015 Ludovic Courtès <[email protected]>
;;; Copyright © 2014 Ian Denhardt <[email protected]>
;;; Copyright © 2014 Eric Bavier <[email protected]>
;;; Copyright © 2014, 2015 Federico Beffa <[email protected]>
@@ -1022,6 +1022,8 @@ widgets built in the loading process.")
(license license:gpl2+))) ; This is correct. GPL not LGPL
(define-public libgnomeprint
+ ;; This library has been deprecated since 2006; see
+ ;; <https://mail.gnome.org/archives/devel-announce-list/2006-August/msg00005.html>.
(package
(name "libgnomeprint")
(version "2.8.2")
@@ -1045,11 +1047,14 @@ widgets built in the loading process.")
("pkg-config" ,pkg-config)))
(home-page "https://projects.gnome.org/gnome-print/home/faq.html")
(synopsis "Printing framework for GNOME")
- (description "Gnome-print is a high-quality printing framework for GNOME.")
+ (description
+ "GNOME-print was a printing framework for GNOME. It has been deprecated
+since ca. 2006, when GTK+ itself incorporated printing support.")
(license license:lgpl2.0+)))
(define-public libgnomeprintui
+ ;; Deprecated; see libgnomeprint.
(package
(name "libgnomeprintui")
(version "2.8.2")
@@ -1074,10 +1079,9 @@ widgets built in the loading process.")
("pkg-config" ,pkg-config)))
(home-page "https://projects.gnome.org/gnome-print/home/faq.html")
(synopsis "Printing framework for GNOME")
- (description "Gnome-print is a high-quality printing framework for GNOME.")
+ (description (package-description libgnomeprint))
(license license:lgpl2.0+)))
-
(define-public libbonoboui
(package
(name "libbonoboui")
@@ -1442,3 +1446,31 @@ editors, IDEs, etc.")
is to provide a backend to GSettings on platforms that don't already have
configuration storage systems.")
(license license:lgpl2.1)))
+
+(define-public json-glib
+ (package
+ (name "json-glib")
+ (version "1.0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "02k66lpc4cmgygj66n8zcy59bggy7yzm3v4hni9xqplgva9d2yw8"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("glib" ,glib "bin") ; for glib-mkenums and glib-genmarshal
+ ("gobject-introspection" ,gobject-introspection)
+ ("pkg-config" ,pkg-config)))
+ (propagated-inputs
+ `(("glib" ,glib))) ; according to json-glib-1.0.pc
+ (home-page "https://wiki.gnome.org/Projects/JsonGlib")
+ (synopsis "Compiler for the GObject type system")
+ (description "JSON-GLib is a C library based on GLib providing
+serialization and deserialization support for the JavaScript Object Notation
+(JSON) format described by RFC 4627. It provides parser and generator
+GObject classes and various wrappers for the complex data types employed by
+JSON, such as arrays and objects.")
+ (license license:lgpl2.1+)))