summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm46
1 files changed, 21 insertions, 25 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 820a44cbde..7fd43221f3 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -99,15 +99,15 @@
(define dbus
(package
(name "dbus")
- (version "1.12.20")
+ (version "1.14.0")
(source (origin
(method url-fetch)
(uri (string-append
"https://dbus.freedesktop.org/releases/dbus/dbus-"
- version ".tar.gz"))
+ version ".tar.xz"))
(sha256
(base32
- "1zp5gpx61v1cpqf2zwb1cidhp9xylvw49d3zydkxqk6b1qa20xpp"))
+ "1m7bibavml4gx9d67j403l0kzd1a4z8lhrpxb2as3q4nfpiwrmyc"))
(patches (search-patches "dbus-helper-search-path.patch"))))
(build-system gnu-build-system)
(arguments
@@ -211,7 +211,7 @@ information, refer to the @samp{dbus-daemon(1)} man page.")))
(define glib
(package
(name "glib")
- (version "2.70.2")
+ (version "2.72.3")
(source
(origin
(method url-fetch)
@@ -220,7 +220,7 @@ information, refer to the @samp{dbus-daemon(1)} man page.")))
name "/" (string-take version 4) "/"
name "-" version ".tar.xz"))
(sha256
- (base32 "0vw08p4jllavp9qmlqg1yl1zanmy53yid46wipas6gfdhnf4al85"))
+ (base32 "1w25sf2wxkkah2p2w189q58mza3zv8z1fh2q1m82sldq4kva4faa"))
(patches
(search-patches "glib-appinfo-watch.patch"
"glib-skip-failing-test.patch"))
@@ -459,14 +459,14 @@ be used when cross-compiling."
(define gobject-introspection
(package
(name "gobject-introspection")
- (version "1.66.1")
+ (version "1.72.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/"
"gobject-introspection/" (version-major+minor version)
"/gobject-introspection-" version ".tar.xz"))
(sha256
- (base32 "078n0q7b6z682mf4irclrksm73cyixq295mqnqifl9plwmgaai6x"))
+ (base32 "1g5aps3b20ck96ahy7fjl4nhp9nabkd9rlqd0s1qzn3111cqxzh2"))
(patches (search-patches
"gobject-introspection-cc.patch"
"gobject-introspection-girepository.patch"
@@ -515,11 +515,7 @@ be used when cross-compiling."
("bison" ,bison)
("flex" ,flex)))
(inputs
- `(,@(if (%current-target-system)
- `(("python" ,python))
- `(("bison" ,bison)
- ("flex" ,flex)
- ("python" ,python-wrapper)))
+ `(("python" ,python)
("zlib" ,zlib)))
(propagated-inputs
(list glib
@@ -599,27 +595,25 @@ The intltool collection can be used to do these things:
(define itstool
(package
(name "itstool")
- (version "2.0.6")
+ (version "2.0.7")
(source (origin
(method url-fetch)
(uri (string-append "http://files.itstool.org/itstool/itstool-"
version ".tar.bz2"))
(sha256
(base32
- "1acjgf8zlyk7qckdk19iqaca4jcmywd7vxjbcs1mm6kaf8icqcv2"))))
+ "1jl7gsr7aclb9nvqazr039m86y7f7ivfhl2pixcrbfqjkb97r6kb"))))
(build-system gnu-build-system)
(inputs
(list libxml2 python-libxml2 python))
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'install 'wrap-program
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((prog (string-append (assoc-ref outputs "out")
- "/bin/itstool")))
- (wrap-program prog
- `("GUIX_PYTHONPATH" = (,(getenv "GUIX_PYTHONPATH"))))
- #t))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'wrap-program
+ (lambda _
+ (wrap-program (string-append #$output "/bin/itstool")
+ `("GUIX_PYTHONPATH" = (,(getenv "GUIX_PYTHONPATH")))))))))
(home-page "https://itstool.org")
(synopsis "Tool to translate XML documents with PO files")
(description
@@ -851,7 +845,7 @@ useful for C++.")
(define-public python-pygobject
(package
(name "python-pygobject")
- (version "3.40.1")
+ (version "3.42.1")
(source
(origin
(method url-fetch)
@@ -860,7 +854,7 @@ useful for C++.")
"/pygobject-" version ".tar.xz"))
(sha256
(base32
- "0d80g5kgf2i9cginyhalvb7ibfk9g30yilqzmcsw6h6byj8xbih0"))
+ "1j9w1ywsjzvzbwd16mad001vv19j6llb8zjsxd25xqsdcbvvad0z"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -896,6 +890,8 @@ useful for C++.")
(synopsis "Python bindings for GObject")
(description
"Python bindings for GLib, GObject, and GIO.")
+ (properties
+ '((upstream-name . "pygobject")))
(license license:lgpl2.1+)))
(define-public perl-glib