summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm79
1 files changed, 60 insertions, 19 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 3b288cc8b8..1b7faa97c9 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -6817,15 +6817,14 @@ some graphical niceities, and numerous bug-fixes and other improvements.")
(define-public yamagi-quake2
(package
(name "yamagi-quake2")
- (version "7.10")
+ (version "7.45")
(source
(origin
(method url-fetch)
(uri (string-append "https://deponie.yamagi.org/quake2/quake2-"
version ".tar.xz"))
(sha256
- (base32
- "0psinbg25mysd58k99s1n34w31w5hj1vppb39gdjb0zqi6sl6cps"))))
+ (base32 "0rgz8x7lzd0zb0xqd0gvnf2641nr9xpfm6v14mgh99hspxklaln7"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f
@@ -6854,12 +6853,15 @@ some graphical niceities, and numerous bug-fixes and other improvements.")
(string-append out "/bin/yamagi-quake2"))
(symlink (string-append out "/lib/yamagi-quake2/q2ded")
(string-append out "/bin/yamagi-q2ded"))))))))
- (inputs `(("sdl2" ,sdl2)
- ("mesa" ,mesa)
- ("libvorbis" ,libvorbis)
- ("zlib" ,zlib)
- ("openal" ,openal)))
- (native-inputs `(("pkg-config" ,pkg-config)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("curl" ,curl-minimal)
+ ("libvorbis" ,libvorbis)
+ ("mesa" ,mesa)
+ ("openal" ,openal)
+ ("sdl2" ,sdl2)
+ ("zlib" ,zlib)))
(synopsis "First person shooter engine based on quake2")
(description "Yamagi Quake II is an enhanced client for id Software's Quake II.
The main focus is an unchanged single player experience like back in 1997,
@@ -6877,17 +6879,23 @@ making Yamagi Quake II one of the most solid Quake II implementations available.
(define-public nudoku
(package
(name "nudoku")
- (version "1.0.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/jubalh/nudoku/"
- "releases/download/" version
- "/nudoku-" version ".tar.xz"))
- (sha256
- (base32
- "0nr2j2z07nxk70s8xnmmpzccxicf7kn5mbwby2kg6aq8paarjm8k"))))
+ (version "2.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jubalh/nudoku.git")
+ (commit version)))
+ (sha256
+ (base32 "12v00z3p0ymi8f3w4b4bgl4c76irawn3kmd147r0ap6s9ssx2q6m"))))
(build-system gnu-build-system)
- (inputs `(("ncurses" ,ncurses)))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("gettext" ,gettext-minimal)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("ncurses" ,ncurses)))
(home-page "https://jubalh.github.io/nudoku/")
(synopsis "Sudoku for your terminal")
(description "Nudoku is a ncurses-based Sudoku game for your terminal.")
@@ -8284,6 +8292,39 @@ and cooperative.")
;; developers.
(license (list license:gpl2+ license:lgpl2.1+))))
+(define-public slimevolley
+ (package
+ (name "slimevolley")
+ (version "2.4.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://download.tuxfamily.org/slime/"
+ "slimevolley_" version ".tar.gz"))
+ (sha256
+ (base32 "1pi60zjpx95mfdkrbwf4cbzy5lv4v5qrljvgck46qca78i9g9g46"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ;no test
+ ;; Work around build failure: "error adding symbols: DSO
+ ;; missing from command line".
+ #:configure-flags (list "-DCMAKE_EXE_LINKER_FLAGS=-lm")))
+ (native-inputs
+ `(("gettext" ,gettext-minimal)))
+ (inputs
+ `(("sdl" ,(sdl-union (list sdl sdl-image sdl-net sdl-ttf)))))
+ (home-page "https://slime.tuxfamily.org/")
+ (synopsis "Unrealistic 2D volleyball simulation")
+ (description
+ "Slime Volley is a 2D arcade-oriented volleyball simulation, in
+the spirit of some Java games of the same name.
+
+Two teams, 1-3 players each, try to be the first to get 10 points.
+This happens when the one ball touches the floor on the other side of
+the net. There can be 1 to 8 balls in game. Once one ball touches
+the ground, the set ends and all balls are served again.")
+ (license license:gpl3+)))
+
(define-public slingshot
(package
(name "slingshot")