summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm32
1 files changed, 31 insertions, 1 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index c0319dcb20..5a27193e57 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -30,7 +30,7 @@
;;; Copyright © 2017, 2019, 2020 Marius Bakke <[email protected]>
;;; Copyright © 2017, 2018 Rutger Helling <[email protected]>
;;; Copyright © 2017 Roel Janssen <[email protected]>
-;;; Copyright © 2017-2024 Nicolas Goaziou <[email protected]>
+;;; Copyright © 2017-2025 Nicolas Goaziou <[email protected]>
;;; Copyright © 2018 okapi <[email protected]>
;;; Copyright © 2018 Tim Gesthuizen <[email protected]>
;;; Copyright © 2018 Madalin Ionel-Patrascu <[email protected]>
@@ -10716,6 +10716,36 @@ the game is to stay alive and collect prizes. The robot program conveniently
may be written in a plain text file in the Scheme programming language.")
(license license:gpl3+)))
+(define-public li-ri
+ (package
+ (name "li-ri")
+ (version "3.1.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/petitlapin/Li-Ri")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1fd5hl9qhgvyix51la8sl34jzk4mcin8sai05gidy2r2grb1dy4s"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:tests? #false ;no tests
+ #:configure-flags
+ #~(list "-DUSE_SYSTEM_SIMPLEINI=ON"
+ (string-append "-DLIRI_DATA_DIR=" #$output "/share/Li-ri/"))))
+ (native-inputs (list pkg-config))
+ (inputs (list sdl2 sdl2-mixer simpleini))
+ (home-page "https://github.com/petitlapin/Li-Ri")
+ (synopsis "Toy train simulation game")
+ (description
+ "Li-Ri is a game in which you drive a wooden toy steam locomotive
+across many levels and collect all the coaches to win.")
+ ;; Source files mention "either version 2 or version 3" for GPL
+ ;; license. Desktop file is licensed under CC0 terms.
+ (license (list license:gpl2 license:gpl3 license:cc0))))
+
(define-public ri-li
(package
(name "ri-li")