summaryrefslogtreecommitdiff
path: root/gnu/packages/file.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/file.scm')
-rw-r--r--gnu/packages/file.scm19
1 files changed, 17 insertions, 2 deletions
diff --git a/gnu/packages/file.scm b/gnu/packages/file.scm
index f811ba77c7..5e379d888b 100644
--- a/gnu/packages/file.scm
+++ b/gnu/packages/file.scm
@@ -3,6 +3,9 @@
;;; Copyright © 2014, 2015 Mark H Weaver <[email protected]>
;;; Copyright © 2016, 2017, 2018 Efraim Flashner <[email protected]>
;;; Copyright © 2018 Tobias Geerinckx-Rice <[email protected]>
+;;; Copyright © 2018 Efraim Flashner <[email protected]>
+;;; Copyright © 2020 Michael Rohleder <[email protected]>
+;;; Copyright © 2021 Marius Bakke <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -29,14 +32,14 @@
(define-public file
(package
(name "file")
- (version "5.38")
+ (version "5.39")
(source (origin
(method url-fetch)
(uri (string-append "ftp://ftp.astron.com/pub/file/file-"
version ".tar.gz"))
(sha256
(base32
- "0d7s376b4xqymnrsjxi3nsv3f5v89pzfspzml2pcajdk5by2yg2r"))))
+ "1lgs2w2sgamzf27kz5h7pajz7v62554q21fbs11n4mfrfrm2hpgh"))))
(build-system gnu-build-system)
;; When cross-compiling, this package depends upon a native install of
@@ -55,3 +58,15 @@ extensions to tell you the type of a file, but looks at the actual contents
of the file. This package provides the libmagic library.")
(license bsd-2)
(home-page "https://www.darwinsys.com/file/")))
+
+(define-public file-next
+ (package
+ (inherit file)
+ (version "5.41")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://ftp.astron.com/pub/file/file-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0gv027jgdr0hdkw7m9ck0nwhq583f4aa7vnz4dzdbxv4ng3k5r8k"))))))