summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm94
1 files changed, 84 insertions, 10 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index b1e2db8344..a845c312d6 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -71,6 +71,7 @@
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system trivial)
#:use-module (gnu packages)
+ #:use-module (gnu packages admin)
#:use-module (gnu packages audio)
#:use-module (gnu packages bash)
#:use-module (gnu packages cmake)
@@ -1360,7 +1361,7 @@ a set of simplified face specifications and a user-supplied color palette")
(guix build emacs-utils))
#:phases
(modify-phases %standard-phases
- (add-after 'rename-lispdir 'make-autoloads
+ (add-after 'install 'make-autoloads
(assoc-ref emacs:%standard-phases 'make-autoloads)))))
(home-page "http://howm.osdn.jp/")
(synopsis "Note-taking tool for Emacs")
@@ -1372,7 +1373,7 @@ searches. Unlike code@{emacs-wiki.el}, it can be combined with any format.")
(define-public emacs-calfw
(package
(name "emacs-calfw")
- (version "1.5")
+ (version "1.6")
(source
(origin
(method url-fetch)
@@ -1382,7 +1383,7 @@ searches. Unlike code@{emacs-wiki.el}, it can be combined with any format.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "17ssg8gx66yp63nhygjq2r6kgl4h45cacmrxsxs9f0lrfcx37k0l"))))
+ "1zr91xr0f1xfcv78yxka8vs5ximmq2ixmqf2pkb57kwwnxlypq4i"))))
(build-system emacs-build-system)
(propagated-inputs
`(("emacs-howm" ,emacs-howm)))
@@ -2880,6 +2881,50 @@ with irony-mode using clang-tooling.")
(home-page "https://github.com/Sarcasm/company-irony")
(license license:gpl3+)))
+(define-public emacs-flycheck-irony
+ (package
+ (name "emacs-flycheck-irony")
+ (version "0.1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Sarcasm/flycheck-irony.git")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "0qa5a8wzvzxwqql92ibc9s43k8sj3vwn7skz9hfr8av0skkhx996"))
+ (file-name (string-append name "-" version))))
+ (build-system emacs-build-system)
+ (inputs
+ `(("irony-mode" ,emacs-irony-mode)
+ ("flycheck-mode" ,emacs-flycheck)
+ ("emacs-company" ,emacs-company)))
+ (synopsis "Live syntax checking frontend for Flycheck using irony-mode")
+ (description "This package provides a frontend for Flycheck that lets
+irony-mode do the syntax checking.")
+ (home-page "https://github.com/Sarcasm/flycheck-irony")
+ (license license:gpl3+)))
+
+(define-public emacs-irony-eldoc
+ (package
+ (name "emacs-irony-eldoc")
+ (version (package-version emacs-irony-mode))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ikirill/irony-eldoc.git")
+ (commit "0df5831eaae264a25422b061eb2792aadde8b3f2")))
+ (sha256 (base32 "1l5qpr66v1l12fb50yh73grb2rr85xxmbj19mm33b5rdrq2bqmmd"))
+ (file-name (string-append name "-" version))))
+ (build-system emacs-build-system)
+ (inputs
+ `(("irony-mode" ,emacs-irony-mode)))
+ (synopsis "Eldoc integration for irony-mode")
+ (description "Irony-eldoc is an eldoc extension that shows documentation
+for the current function or variable in the minibuffer.")
+ (home-page "https://github.com/ikirill/irony-eldoc")
+ (license license:gpl3+)))
+
(define-public emacs-company-quickhelp
(package
(name "emacs-company-quickhelp")
@@ -4397,7 +4442,7 @@ to all the other commands, too.")
(define-public emacs-js2-mode
(package
(name "emacs-js2-mode")
- (version "20150909")
+ (version "20180301")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/mooz/js2-mode/archive/"
@@ -4405,7 +4450,7 @@ to all the other commands, too.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1nsm36c4kwb473p13i58fgrnlk8fbn3rdhj47d9xz70az4ra44q0"))))
+ "13aghgwaqrmbf3pbifcry52kya454wnh1gbdh5805n1n6xgjm5w3"))))
(build-system emacs-build-system)
(home-page "https://github.com/mooz/js2-mode/")
(synopsis "Improved JavaScript editing mode for Emacs")
@@ -7979,6 +8024,35 @@ takes only a few lines of code. Polymode also provides extensible facilities
for external literate programming tools for exporting, weaving and tangling.")
(license license:gpl3+)))
+(define-public emacs-polymode-ansible
+ (let ((commit "b26094d029e25dc797b94254f797e7807a57e4c8"))
+ (package
+ (name "emacs-polymode-ansible")
+ ;; No upstream version release yet.
+ (version (git-version "0.1" "1" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/mavit/poly-ansible")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "055shddqibib3hx2ykwdz910nrqws40cd407mq946l2bf6v87gj6"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-ansible-doc" ,emacs-ansible-doc)
+ ("emacs-jinja2-mode" ,emacs-jinja2-mode)
+ ("emacs-polymode" ,emacs-polymode)
+ ("emacs-yaml-mode" ,emacs-yaml-mode)))
+ (properties '((upstream-name . "poly-ansible")))
+ (home-page "https://gitlab.com/mavit/poly-ansible/")
+ (synopsis "Polymode for Ansible - Jinja2 in YAML")
+ (description
+ "Edit YAML files for Ansible containing embedded Jinja2 templating.")
+ (license license:gpl3+))))
+
(define-public eless
(package
(name "eless")
@@ -11485,7 +11559,7 @@ the GIF result.")
(define-public emacs-google-translate
(package
(name "emacs-google-translate")
- (version "0.11.15")
+ (version "0.11.16")
(source
(origin
(method url-fetch)
@@ -11494,7 +11568,7 @@ the GIF result.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1zxvfagbaf5mxi528mz33c8vxdk86wj0xx5y2jfy97wi8dzrwn3g"))))
+ "01n9spj1d0gjfj39x526rl3m9c28wnx9afipmf5s8y77cx3mfwhl"))))
(build-system emacs-build-system)
(home-page "https://github.com/atykhonov/google-translate")
(synopsis "Emacs interface to Google Translate")
@@ -11846,10 +11920,10 @@ file.")
(deprecated-package "emacs-wgrep-helm" emacs-wgrep))
(define-public emacs-mu4e-conversation
- (let ((commit "54368a009474276247bdf39683e25ea68ae1f943"))
+ (let ((commit "e7d4bfcb0d392b0aed1f705ccac2419a168d1f5e"))
(package
(name "emacs-mu4e-conversation")
- (version (git-version "20181105" "3" commit))
+ (version (git-version "20181126" "4" commit))
(source
(origin
(method url-fetch)
@@ -11860,7 +11934,7 @@ file.")
(file-name (string-append name "-" version "-checkout"))
(sha256
(base32
- "1zqnp1d3cxyvzsd76d5iw40lkif19k9svlbhqy6dvqiaqm0jbd15"))))
+ "0b52hf9rm2afba9pvgink9bwqm705sk0y5qikp0ff5sk53wqvy29"))))
(build-system emacs-build-system)
(propagated-inputs
`(("mu" ,mu)))