summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm35
1 files changed, 27 insertions, 8 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6865346cf0..91b1230489 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -8668,7 +8668,7 @@ indentation guides in Emacs:
(define-public emacs-elpy
(package
(name "emacs-elpy")
- (version "1.34.0")
+ (version "1.35.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -8677,7 +8677,7 @@ indentation guides in Emacs:
(file-name (git-file-name name version))
(sha256
(base32
- "1x1z298axbh4xalssnq9nkf2z1sdgmx839vb01xz18kr9lfavx1x"))))
+ "07rdb9w3bxzfr07224awa541xdy116hyc2b3bpl3fc3ikddmbydk"))))
(build-system emacs-build-system)
(arguments
`(#:include (cons* "^elpy/[^/]+\\.py$" "^snippets\\/" %default-include)
@@ -11189,7 +11189,7 @@ highlights quasi-quoted expressions.")
(define-public emacspeak
(package
(name "emacspeak")
- (version "52.0")
+ (version "53.0")
(source
(origin
(method url-fetch)
@@ -11197,17 +11197,13 @@ highlights quasi-quoted expressions.")
"https://github.com/tvraman/emacspeak/releases/download/"
version "/emacspeak-" version ".tar.bz2"))
(sha256
- (base32 "0x5b0s38r5ih2lk7f5hasi9arrgxlmmq5jaddadbxi8in2gw2jzl"))))
+ (base32 "0lasj4ggsh93ingf46n16wxfx5zzxvr1igikbmdqlz3i99j331gs"))))
(build-system gnu-build-system)
(arguments
'(#:make-flags (list (string-append "prefix="
(assoc-ref %outputs "out")))
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'delete-broken-symlink
- (lambda _
- (delete-file "lisp/sudoku.el")
- #t))
(replace 'configure
(lambda _
(setenv "SHELL" (which "sh"))
@@ -22997,6 +22993,29 @@ contains a track position, playback will start at the specified position.")
JIRA issue servers.")
(license license:gpl3+)))
+(define-public emacs-slime-volleyball
+ (package
+ (name "emacs-slime-volleyball")
+ (version "1.1.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://elpa.gnu.org/packages/"
+ "slime-volleyball-" version ".tar"))
+ (sha256
+ (base32 "1jsx889j09jbib9v3jzn3k2hn71jzdyc5yv4f010l6fknbsfi7lr"))))
+ (build-system emacs-build-system)
+ (arguments '(#:include '("\\.el$" "\\.svg$" "\\.b64$" "slime\\.el\\.gz$")))
+ (home-page "http://elpa.gnu.org/packages/slime-volleyball.html")
+ (synopsis "SVG slime volleyball game")
+ (description
+ "Emacs Slime Volleyball is a volleyball game. Win points by
+making the ball land on your opponent's side of the court. The first
+player to five points wins! You can play against a friend, or
+challenge the three computer opponents in one player mode. You can
+even train opponent slimes.")
+ (license license:gpl3+)))
+
(define-public emacs-systemd-mode
(package
(name "emacs-systemd-mode")