summaryrefslogtreecommitdiff
path: root/gnu/packages/diffoscope.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/diffoscope.scm')
-rw-r--r--gnu/packages/diffoscope.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index 4b5f7a1030..2dc3cfad0f 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2018 Julien Lepiller <[email protected]>
;;; Copyright © 2018, 2019 Rutger Helling <[email protected]>
;;; Copyright © 2019 Vagrant Cascadian <[email protected]>
+;;; Copyright © 2022 Efraim Flashner <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -176,10 +177,15 @@
;; XXX: Must be the same version as python-magic uses;
;; remove when 'file' is updated.
- file-next
+ file-next)
- fpc
- gettext-minimal
+ (match (%current-system)
+ ;; fpc is only available on x86 currently.
+ ((or "x86_64-linux" "i686-linux")
+ (list fpc))
+ (_ '()))
+
+ (list gettext-minimal
ghostscript
`(,giflib "bin")
gnumeric