summaryrefslogtreecommitdiff
path: root/gnu/packages/datastructures.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/datastructures.scm')
-rw-r--r--gnu/packages/datastructures.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/datastructures.scm b/gnu/packages/datastructures.scm
index 07cd2aa872..4fa38ee3d4 100644
--- a/gnu/packages/datastructures.scm
+++ b/gnu/packages/datastructures.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2015, 2016, 2018, 2019 Ricardo Wurmus <[email protected]>
;;; Copyright © 2016, 2017, 2019–2021 Tobias Geerinckx-Rice <[email protected]>
;;; Copyright © 2018 Meiyo Peng <[email protected]>
-;;; Copyright © 2019, 2020 Efraim Flashner <[email protected]>
+;;; Copyright © 2019, 2020, 2022 Efraim Flashner <[email protected]>
;;; Copyright © 2020 Mark H Weaver <[email protected]>
;;; Copyright © 2020 Marius Bakke <[email protected]>
;;;
@@ -155,7 +155,7 @@ synchronisation library. It provides read-side access that scales linearly
with the number of cores. liburcu-cds provides efficient data structures
based on RCU and lock-free algorithms. These structures include hash tables,
queues, stacks, and doubly-linked lists.")
- (license license:lgpl2.1+)))
+ (license (list license:lgpl2.1 license:expat))))
(define-public uthash
(package
@@ -266,7 +266,7 @@ to the structure and choosing one or more fields to act as the key.")
Cflags: -I${includedir}~%"
out ,version)))
#t))))))
- (native-inputs
+ (propagated-inputs
(list libdivsufsort))
(home-page "https://github.com/simongog/sdsl-lite")
(synopsis "Succinct data structure library")