summaryrefslogtreecommitdiff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm23
1 files changed, 16 insertions, 7 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 26769d2626..42df348f29 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2014 Andreas Enge <[email protected]>
;;; Copyright © 2012 Nikita Karetnikov <[email protected]>
;;; Copyright © 2014, 2015, 2017 Mark H Weaver <[email protected]>
-;;; Copyright © 2017, 2018, 2019, 2021 Efraim Flashner <[email protected]>
+;;; Copyright © 2017, 2018, 2019, 2021, 2022 Efraim Flashner <[email protected]>
;;; Copyright © 2018 Tobias Geerinckx-Rice <[email protected]>
;;; Copyright © 2018, 2019, 2020 Jan (janneke) Nieuwenhuizen <[email protected]>
;;; Copyright © 2019, 2020, 2021 Marius Bakke <[email protected]>
@@ -3146,8 +3146,7 @@ memoized as a function of '%current-system'."
`(,@(%boot0-inputs)
("expat" ,expat-sans-tests))) ;remove OpenSSL, zlib, etc.
(native-inputs ;and pkg-config
- `(("sitecustomize.py" ,(local-file (search-auxiliary-file
- "python/sitecustomize.py")))))
+ `())
(arguments
`(#:implicit-inputs? #f
#:guile ,%bootstrap-guile
@@ -3173,6 +3172,13 @@ memoized as a function of '%current-system'."
;; Prevent the 'ossaudiodev' extension from being
;; built, since it requires Linux headers.
(("'linux', ") ""))))
+ (add-after 'install 'remove-tests
+ (lambda* (#:key outputs #:allow-other-keys)
+ (delete-file-recursively
+ (string-append (assoc-ref outputs "out")
+ "/lib/python"
+ ,(version-major+minor version)
+ "/test"))))
,@(if (hurd-system?)
`((add-before 'build 'fix-regen
(lambda* (#:key inputs #:allow-other-keys)
@@ -3180,11 +3186,14 @@ memoized as a function of '%current-system'."
(substitute* "Lib/plat-generic/regen"
(("/usr/include/")
(string-append libc "/include/")))))))
- '())
- (add-after 'install 'install-sitecustomize.py
- ,(customize-site version)))))
+ '()))))
(native-search-paths
- (list (guix-pythonpath-search-path version)))))
+ (list (search-path-specification
+ (variable "PYTHONPATH")
+ (files (list (string-append
+ "lib/python"
+ (version-major+minor version)
+ "/site-packages"))))))))
(define/system-dependent ld-wrapper-boot0
;; The first 'ld' wrapper, defined with 'define/system-dependent' because