summaryrefslogtreecommitdiff
path: root/gnu/packages/bootstrap.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bootstrap.scm')
-rw-r--r--gnu/packages/bootstrap.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
index 602d8f26c5..a36bb289cd 100644
--- a/gnu/packages/bootstrap.scm
+++ b/gnu/packages/bootstrap.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <[email protected]>
;;; Copyright © 2014, 2015, 2018, 2019 Mark H Weaver <[email protected]>
-;;; Copyright © 2017, 2020 Efraim Flashner <[email protected]>
+;;; Copyright © 2017, 2020, 2024 Efraim Flashner <[email protected]>
;;; Copyright © 2018, 2020, 2022 Jan (janneke) Nieuwenhuizen <[email protected]>
;;; Copyright © 2019 Carl Dong <[email protected]>
;;; Copyright © 2019 Léo Le Bouter <[email protected]>
@@ -323,6 +323,9 @@ or false to signal an error."
((string=? system "powerpc64-linux") "/lib/ld64.so.1")
((string=? system "alpha-linux") "/lib/ld-linux.so.2")
+ ;; TODO: Differentiate between x86_64-linux-gnu and x86_64-linux-gnux32.
+ ((string=? system "x86_64-linux-gnux32") "/lib/ld-linux-x32.so.2")
+
;; XXX: This one is used bare-bones, without a libc, so add a case
;; here just so we can keep going.
((string=? system "arm-eabi") "no-ld.so")