summaryrefslogtreecommitdiff
path: root/etc
diff options
context:
space:
mode:
Diffstat (limited to 'etc')
-rwxr-xr-xetc/guix-install.sh25
-rw-r--r--etc/news.scm45
-rw-r--r--etc/release-manifest.scm2
-rw-r--r--etc/snippets/yas/scheme-mode/guix-news-entry9
-rw-r--r--etc/teams.scm.in17
5 files changed, 88 insertions, 10 deletions
diff --git a/etc/guix-install.sh b/etc/guix-install.sh
index 3ce9affc06..ea10f35250 100755
--- a/etc/guix-install.sh
+++ b/etc/guix-install.sh
@@ -29,6 +29,22 @@
# We require Bash but for portability we'd rather not use /bin/bash or
# /usr/bin/env in the shebang, hence this hack.
+
+# Environment variables
+#
+# GUIX_BINARY_FILE_NAME
+#
+# Can be used to override the automatic download mechanism and point
+# to a local Guix binary archive filename like
+# "/tmp/guix-binary-1.4.0rc2.armhf-linux.tar.xz"
+#
+# GUIX_ALLOW_OVERWRITE
+#
+# Instead of aborting to avoid overwriting a previous installations,
+# allow copying over /var/guix or /gnu. This can be useful when the
+# installation required the user to extract Guix packs under /gnu to
+# satisfy its dependencies.
+
if [ "x$BASH_VERSION" = "x" ]
then
exec bash "$0" "$@"
@@ -336,16 +352,15 @@ sys_create_store()
_debug "--- [ ${FUNCNAME[0]} ] ---"
- if [[ -e "/var/guix" || -e "/gnu" ]]; then
+ if [[ -z $GUIX_ALLOW_OVERWRITE && (-e /var/guix || -e /gnu) ]]; then
die "A previous Guix installation was found. Refusing to overwrite."
+ else
+ _msg "${WAR}Overwriting existing installation!"
fi
cd "$tmp_path"
- tar --extract --file "$pkg" && _msg "${PAS}unpacked archive"
-
_msg "${INF}Installing /var/guix and /gnu..."
- mv "${tmp_path}/var/guix" /var/
- mv "${tmp_path}/gnu" /
+ tar --extract --file "$pkg" -C /
_msg "${INF}Linking the root user's profile"
mkdir -p ~root/.config/guix
diff --git a/etc/news.scm b/etc/news.scm
index 211a176170..924c2b35b4 100644
--- a/etc/news.scm
+++ b/etc/news.scm
@@ -4,12 +4,12 @@
;; Copyright © 2019–2021 Tobias Geerinckx-Rice <[email protected]>
;; Copyright © 2019, 2020 Miguel Ángel Arruga Vivas <[email protected]>
;; Copyright © 2019, 2020 Konrad Hinsen <[email protected]>
-;; Copyright © 2019, 2020, 2021 Julien Lepiller <[email protected]>
+;; Copyright © 2019, 2020, 2021, 2023 Julien Lepiller <[email protected]>
;; Copyright © 2019–2023 Florian Pelz <[email protected]>
;; Copyright © 2020, 2022 Marius Bakke <[email protected]>
;; Copyright © 2020, 2021 Mathieu Othacehe <[email protected]>
;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <[email protected]>
-;; Copyright © 2020, 2021, 2022 Maxim Cournoyer <[email protected]>
+;; Copyright © 2020, 2021, 2022, 2023 Maxim Cournoyer <[email protected]>
;; Copyright © 2021 Leo Famulari <[email protected]>
;; Copyright © 2021 Zhu Zihao <[email protected]>
;; Copyright © 2021 Chris Marusich <[email protected]>
@@ -26,6 +26,47 @@
(channel-news
(version 0)
+ (entry (commit "598f4c509bbfec2b983a8ee246cce0a0fe45ec7f")
+ (title
+ (de "Neues Format @samp{rpm} für den Befehl @command{guix pack}")
+ (en "New @samp{rpm} format for the @command{guix pack} command")
+ (fr "Nouveau format @samp{rpm} pour la commande @command{guix pack}"))
+ (body
+ (de "Sie können jetzt auch RPM-Archive (mit der Dateinamenserweiterung
+.rpm) erzeugen mit dem Befehl @command{guix pack --format=rpm}. Damit
+haben Sie einen alternativen Distributionsweg für mit Guix erstellte
+Software. Hier sehen Sie ein einfaches Beispiel, wie Sie ein
+RPM-Archiv für das Paket @code{hello} erzeugen:
+
+@example
+guix pack --format=rpm --symlink=/usr/bin/hello=bin/hello hello
+@end example
+
+Siehe @command{info \"(guix.de) Aufruf von guix pack\"} für mehr
+Informationen.")
+ (en "RPM archives (with the .rpm file extension) can now be produced
+via the @command{guix pack --format=rpm} command, providing an alternative
+distribution path for software built with Guix. Here is a simple example that
+generates an RPM archive for the @code{hello} package:
+
+@example
+guix pack --format=rpm --symlink=/usr/bin/hello=bin/hello hello
+@end example
+
+See @command{info \"(guix) Invoking guix pack\"} for more information.")
+ (fr "Vous pouvez désormais produire une archive RPM (avec l'extension
+.rpm) avec la commande @command{guix pack --format=rpm} qui propose
+donc une nouvelle manière de distribuer les logiciels construits avec
+Guix. Voici un exemple permettant de générer une archive RPM pour le
+paquet @code{hello} :
+
+@example
+guix pack --format=rpm --symlink=/usr/bin/hello=bin/hello hello
+@end example
+
+Consultez @command{info \"(guix.fr) Invoquer guix pack\"} pour plus
+d'informations.")))
+
(entry (commit "137b91f03bbb7f1df71cf10c4f79ae57fbcea400")
(title
(en "New @option{--with-version} package transformation option")
diff --git a/etc/release-manifest.scm b/etc/release-manifest.scm
index 3ef3483300..83983c0738 100644
--- a/etc/release-manifest.scm
+++ b/etc/release-manifest.scm
@@ -82,7 +82,7 @@ TARGET."
;; Packages that must be cross-buildable from x86_64-linux.
;; FIXME: Add (@ (gnu packages gcc) gcc) when <https://bugs.gnu.org/40463>
;; is fixed.
- (append (list (@ (gnu packages guile) guile-3.0/fixed))
+ (append (list (@ (gnu packages guile) guile-3.0/pinned))
(map specification->package
'("coreutils" "grep" "sed" "findutils" "diffutils" "patch"
"gawk" "gettext" "gzip" "xz"
diff --git a/etc/snippets/yas/scheme-mode/guix-news-entry b/etc/snippets/yas/scheme-mode/guix-news-entry
new file mode 100644
index 0000000000..7f5bb21c50
--- /dev/null
+++ b/etc/snippets/yas/scheme-mode/guix-news-entry
@@ -0,0 +1,9 @@
+# -*- mode: snippet -*-
+# name: guix-news-entry
+# key: entry...
+# --
+(entry (commit "$1")
+ (title
+ (en "$2"))
+ (body
+ (en "$3")))
diff --git a/etc/teams.scm.in b/etc/teams.scm.in
index 77c0127bb2..ff913673e8 100644
--- a/etc/teams.scm.in
+++ b/etc/teams.scm.in
@@ -3,7 +3,7 @@
!#
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2022 Ricardo Wurmus <[email protected]>
+;;; Copyright © 2022, 2023 Ricardo Wurmus <[email protected]>
;;; Copyright © 2022 Mathieu Othacehe <[email protected]>
;;; Copyright © 2022 Maxim Cournoyer <[email protected]>
;;;
@@ -142,6 +142,19 @@ and the r-build-system."
"guix/scripts/import/cran.scm"
"tests/cran.scm")))
+(define-team tex
+ (team 'tex
+ #:name "TeX team"
+ #:description
+ "TeX, LaTeX, XeLaTeX, LuaTeX, TeXLive, the texlive-build-system, and
+the \"texlive\" importer."
+ #:scope (list "gnu/packages/tex.scm"
+ "guix/build/texlive-build-system.scm"
+ "guix/build-system/texlive.scm"
+ "guix/import/texlive.scm"
+ "guix/scripts/import/texlive.scm"
+ "tests/texlive.scm")))
+
(define-team julia
(team 'julia
#:name "Julia team"
@@ -490,7 +503,7 @@ importer."
(define-member (person "Ricardo Wurmus"
- r core mentors)
+ r core mentors tex)
(define-member (person "Christopher Baines"