summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk2
-rw-r--r--gnu/packages/java.scm8
-rw-r--r--gnu/packages/patches/openjdk-10-hotspot-pointer-comparison.patch15
-rw-r--r--gnu/packages/patches/openjdk-10-hotspot-stack-size.patch28
4 files changed, 49 insertions, 4 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 65f04b04a6..f7fcc8902f 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1566,6 +1566,8 @@ dist_patch_DATA = \
%D%/packages/patches/openjdk-9-hotspot-pointer-comparison.patch \
%D%/packages/patches/openjdk-9-hotspot-stack-size.patch \
%D%/packages/patches/openjdk-10-idlj-reproducibility.patch \
+ %D%/packages/patches/openjdk-10-hotspot-pointer-comparison.patch \
+ %D%/packages/patches/openjdk-10-hotspot-stack-size.patch \
%D%/packages/patches/openjdk-15-xcursor-no-dynamic.patch \
%D%/packages/patches/openmpi-mtl-priorities.patch \
%D%/packages/patches/openssh-hurd.patch \
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index fda361a4a6..53216cca9d 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -1729,12 +1729,12 @@ new Date();"))
(base32
"0zywq2203b4hx4jms9vbwvjcj1d3k2v3qpx4s33729fkpmid97r4"))
(patches (search-patches
- "openjdk-10-idlj-reproducibility.patch"))
+ "openjdk-10-idlj-reproducibility.patch"
+ "openjdk-10-hotspot-pointer-comparison.patch"
+ "openjdk-10-hotspot-stack-size.patch"))
(modules '((guix build utils)))
(snippet
- `(begin
- (for-each delete-file (find-files "." ".*.(bin|exe|jar)$"))
- #t))))
+ '(for-each delete-file (find-files "." "\\.(bin|exe|jar)$")))))
(arguments
(substitute-keyword-arguments (package-arguments openjdk9)
((#:phases phases)
diff --git a/gnu/packages/patches/openjdk-10-hotspot-pointer-comparison.patch b/gnu/packages/patches/openjdk-10-hotspot-pointer-comparison.patch
new file mode 100644
index 0000000000..2c64d06fbe
--- /dev/null
+++ b/gnu/packages/patches/openjdk-10-hotspot-pointer-comparison.patch
@@ -0,0 +1,15 @@
+Avoid ordered comparison of pointer with integer to prevent compile error
+with GCC 11.
+
+diff --git a/src/hotspot/os/linux/os_linux.cpp b/src/hotspot/os/linux/os_linux.cpp
+--- a/src/hotspot/os/linux/os_linux.cpp
++++ b/src/hotspot/os/linux/os_linux.cpp
+@@ -2155,7 +2155,7 @@ void os::Linux::print_container_info(outputStream* st) {
+ }
+
+ p = OSContainer::cpu_cpuset_memory_nodes();
+- if (p < 0)
++ if (p == NULL)
+ st->print("cpu_memory_nodes() failed\n");
+ else {
+ st->print("cpu_memory_nodes: %s\n", p);
diff --git a/gnu/packages/patches/openjdk-10-hotspot-stack-size.patch b/gnu/packages/patches/openjdk-10-hotspot-stack-size.patch
new file mode 100644
index 0000000000..2c246dbdbc
--- /dev/null
+++ b/gnu/packages/patches/openjdk-10-hotspot-stack-size.patch
@@ -0,0 +1,28 @@
+Dynamically allocate the stack since SIGSTKSZ is not constant since glibc 2.34.
+
+Backported from:
+
+ https://github.com/openjdk/jdk17u/commit/bb7c412e259893091210267252faf3c0a1be0969
+
+diff --git a/test/hotspot/jtreg/runtime/StackGuardPages/exeinvoke.c b/test/hotspot/jtreg/runtime/StackGuardPages/exeinvoke.c
+--- a/test/hotspot/jtreg/runtime/StackGuardPages/exeinvoke.c
++++ b/test/hotspot/jtreg/runtime/StackGuardPages/exeinvoke.c
+@@ -67,8 +67,17 @@ static void handler(int sig, siginfo_t *si, void *unused) {
+ longjmp(context, 1);
+ }
+
++static char* altstack = NULL;
++
+ void set_signal_handler() {
+- static char altstack[SIGSTKSZ];
++ if (altstack == NULL) {
++ // Dynamically allocated in case SIGSTKSZ is not constant
++ altstack = malloc(SIGSTKSZ);
++ if (altstack == NULL) {
++ fprintf(stderr, "Test ERROR. Unable to malloc altstack space\n");
++ exit(7);
++ }
++ }
+
+ stack_t ss = {
+ .ss_size = SIGSTKSZ,