summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/protobuf.scm15
1 files changed, 14 insertions, 1 deletions
diff --git a/gnu/packages/protobuf.scm b/gnu/packages/protobuf.scm
index 52b1337b4d..028b2f21e1 100644
--- a/gnu/packages/protobuf.scm
+++ b/gnu/packages/protobuf.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2014 Ludovic Courtès <[email protected]>
;;; Copyright © 2016 Daniel Pimentel <[email protected]>
;;; Copyright © 2016 Leo Famulari <[email protected]>
-;;; Copyright © 2017 Ricardo Wurmus <[email protected]>
+;;; Copyright © 2017, 2018 Ricardo Wurmus <[email protected]>
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <[email protected]>
;;;
;;; This file is part of GNU Guix.
@@ -109,6 +109,19 @@ yet extensible format. Google uses Protocol Buffers for almost all of its
internal RPC protocols and file formats.")
(license license:bsd-3)))
+(define-public protobuf-next
+ (package (inherit protobuf)
+ (name "protobuf")
+ (version "3.6.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/google/protobuf/releases/"
+ "download/v" version "/protobuf-cpp-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0a955bz59ihrb5wg7dwi12xajdi5pmz4bl0g147rbdwv393jwwxk"))))))
+
;; XXX Remove this old version when no other packages depend on it.
(define-public protobuf-2
(package (inherit protobuf)